aboutsummaryrefslogtreecommitdiffstats
path: root/lang/harbour
diff options
context:
space:
mode:
Diffstat (limited to 'lang/harbour')
-rw-r--r--lang/harbour/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/lang/harbour/Makefile b/lang/harbour/Makefile
index d1dbd99ca77e..ab0ce3ed494f 100644
--- a/lang/harbour/Makefile
+++ b/lang/harbour/Makefile
@@ -42,7 +42,7 @@ MAKE_ENV+= HB_ARCHITECTURE=${HB_ARCHITECTURE} \
HB_WITHOUT_X11=${HB_WITHOUT_X11}
.if !defined(NOPORTDOCS)
-MAKE_ENV+= HB_DOC_INSTALL=${HB_DOC_INSTALL}
+MAKE_ENV+= HB_DOC_INSTALL=${HB_DOC_INSTALL}
.endif
PORTDOCS= *.txt genhtm.bat genhtm.lnk genhtm.rsp
@@ -55,4 +55,12 @@ pre-install:
${MKDIR} ${DOCSDIR}/
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+BROKEN= Leaves files behind on deinstall
+.elif ${ARCH} == "sparc64"
+BROKEN= Does not compile on sparc64: assertion failed
+.endif
+
+.include <bsd.port.post.mk>