aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ifc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/ifc/Makefile')
-rw-r--r--lang/ifc/Makefile179
1 files changed, 106 insertions, 73 deletions
diff --git a/lang/ifc/Makefile b/lang/ifc/Makefile
index a041c1c3a76d..18537108ca60 100644
--- a/lang/ifc/Makefile
+++ b/lang/ifc/Makefile
@@ -6,14 +6,19 @@
#
PORTNAME= ifc
-PORTVERSION= 7.1.038
+PORTVERSION= 8.0.039
CATEGORIES= lang linux devel
MASTER_SITES=
-DISTNAME= l_fc_pc_${PORTVERSION}
-EXTRACT_SUFX= .tar
+DISTNAME= l_fc_pc_${PORTVERSION:C/\.p.+$//}
MAINTAINER= maho@FreeBSD.org
-COMMENT= Intel's Fortran compiler, set up to produce native FreeBSD objects
+COMMENT= Intel's Fortran compiler, set up to produce native FreeBSD binaries
+
+PATCHLEVEL= ${PORTVERSION:C/(.+p)(.+)$/pe\2/}
+.if ${PORTVERSION} != ${PATCHLEVEL}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ ${DISTNAME}_${PATCHLEVEL}${EXTRACT_SUFX}
+.endif
EXTRACT_DEPENDS= rpm2cpio.pl:${PORTSDIR}/archivers/rpm2cpio
@@ -22,107 +27,127 @@ NO_PACKAGE= ${RESTRICTED}
NO_CDROM= ${RESTRICTED}
ONLY_FOR_ARCHS= i386
+CONFLICTS= linux_devtools*
USE_LINUX= yes
USE_REINPLACE= yes
-NO_WRKSUBDIR= yes
NO_FILTER_SHLIBS= yes
-COMPILERDIR= compiler70
+COMPILERDIR= intel_fc_80
PLIST_SUB= COMPILERDIR=${COMPILERDIR}
-PATCH_WRKSRC= ${WRKSRC}/opt/intel/${COMPILERDIR}
+PATCH_WRKSRC= ${WRKSRC}/opt/${COMPILERDIR}
-MAN1= ifc.1
-MANPREFIX= ${PREFIX}/intel/${COMPILERDIR}/
+MAN1= ifc.1 ifort.1
+MANPREFIX= ${PREFIX}/${COMPILERDIR}/
IFC_SITE= http://www.intel.com/software/products/compilers/
.include <bsd.port.pre.mk>
EXTRACT_AFTER_ARGS= | tar -xf - \
+ --exclude intel-isubh\*.rpm \
--exclude \*ia64.rpm \
+ --exclude chklic.64 \
--exclude flexlm64
IFCCFGVAL!= ${UNAME} -r | ${SED} -e 's/\..*//'
+BRANDELF?= /usr/bin/brandelf
+CPIO?= /usr/bin/cpio
OBJCOPY?= /usr/bin/objcopy
-.if !exists(${DISTDIR}/${DIST_SUBDIR}/${DISTNAME}${EXTRACT_SUFX})
-IGNORE= "Go to Intel Premier Support, https://premier.intel.com, to obtain ${DISTFILES}. Product updates such as this compiler are posted regularly on Premier Support. You must have a license to obtain access to Premier Support. If you do not already have a license go to ${IFC_SITE} to review licensing options \(evaluation, commercial, and free non-commercial\) and obtain a license. Put ${DISTFILES} into ${DISTDIR} and run make again"
+.for file in ${DISTFILES}
+.if !exists(${DISTDIR}/${DIST_SUBDIR}/${file})
+IGNORE= "Go to Intel Premier Support, https://premier.intel.com, to obtain ${DISTFILES}. Product updates such as this compiler are posted regularly on Premier Support. You must have a license to obtain access to Premier Support. If you do not already have a license go to ${IFC_SITE} to review licensing options \(evaluation, commercial, and free non-commercial\) and obtain a license. Put ${DISTFILES} into ${DISTDIR} and run make again"
.endif
+.endfor
-.if exists(${LINUXBASE}/boot/kernel.h) #|| \
-# exists(${PREFIX}/intel/compiler60/bin/icc) || \
-# exists(${PREFIX}/intel/compiler70/bin/icc)
-BROKEN= Cannot coexist with linux_devtools or icc
+.if exists(${LINUXBASE}/boot/kernel.h)
+BROKEN= Cannot coexist with linux_devtools
.endif
post-extract:
- @${SED} 's:%%COMPILERDIR%%:${COMPILERDIR}:' ${FILESDIR}/cpio-exclude \
- >${WRKDIR}/cpio-exclude
-.if defined(NOPORTDOCS)
- @${SED} 's:%%COMPILERDIR%%:${COMPILERDIR}:' \
- ${FILESDIR}/cpio-exclude_noportdocs >>${WRKDIR}/cpio-exclude
-.endif
.for i in \
- intel-ifc7-7.1-40.i386.rpm
-# intel-iidb7-7.2.2-78.i386.rpm
- @cd ${WRKSRC} && rpm2cpio.pl 2>/dev/null ${i} | \
- ${CPIO} -idfuE ${WRKDIR}/cpio-exclude --quiet
+ intel-ifort8-8.0-47.i386.rpm
+# intel-iidb7-7.3.2-98.i386.rpm
+ @cd ${WRKSRC} && rpm2cpio.pl 2>/dev/null ${i} | ${CPIO} -idu --quiet
.endfor
pre-patch:
-# Allow everyone to use it
+# Apply patches from Intel.
+.if ${PORTVERSION} != ${PATCHLEVEL}
+ @${BRANDELF} -t Linux ${WRKSRC}_${PATCHLEVEL}/papply
+ @${WRKSRC}_${PATCHLEVEL}/papply ${WRKSRC}_${PATCHLEVEL}/ifort.rtp \
+ ${WRKSRC}/opt/${COMPILERDIR}
+.endif
+# Remove files we do not need on FreeBSD.
+ @for i in `${CAT} ${FILESDIR}/exclude`; do \
+ ${RM} -rf ${WRKSRC}/opt/${COMPILERDIR}/$$i; \
+ done
+.if defined(NOPORTDOCS)
+# Remove docs.
+ @for i in `${CAT} ${FILESDIR}/exclude_noportdocs`; do \
+ ${RM} -rf ${WRKSRC}/opt/${COMPILERDIR}/$$i; \
+ done
+.endif
+# Allow everyone to use it.
@${CHMOD} a+rx ${WRKSRC}/opt
-# Remove unneeded/unsafe access rights
-.for i in docs ia32/include ia32/lib
- @${FIND} ${WRKSRC}/opt/intel/${COMPILERDIR}/${i} -type f -print0 | \
+# Remove unneeded/unsafe access rights.
+.for i in doc include lib
+ @${FIND} ${WRKSRC}/opt/${COMPILERDIR}/${i} -type f -print0 | \
${XARGS} -0 ${CHMOD} a-x,g-w
.endfor
@${FIND} ${WRKSRC}/opt -type d -print0 | ${XARGS} -0 ${CHMOD} go-w
-# Use the Linux ABI for the binaries
-.for i in ifcbin fpp icid f90com profmerge proforder xiar xild
- @brandelf -t Linux ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/${i}
-.endfor
post-patch:
# Correct some paths and patch some files
-.for i in ia32/bin/ifc ia32/bin/ifcvars.csh ia32/bin/ifcvars.sh
+.for i in ifc ifort ifortvars.csh ifortvars.sh ifc.cfg ifort.cfg
@${REINPLACE_CMD} -i "" -e 's:%%ICC_LOCALBASE%%:${LOCALBASE}:g; \
- s@\<INSTALLDIR\>@${PREFIX}/intel@g; s@man -w@manpath -q@g' \
- ${WRKSRC}/opt/intel/${COMPILERDIR}/${i}
- @${CHMOD} 755 ${WRKSRC}/opt/intel/${COMPILERDIR}/${i}
+ s:\<INSTALLDIR\>:${PREFIX}/${COMPILERDIR}:g; \
+ s:man -w:manpath -q:g' ${WRKSRC}/opt/${COMPILERDIR}/bin/${i}
+ @${CHMOD} 755 ${WRKSRC}/opt/${COMPILERDIR}/bin/${i}
.endfor
- @${REINPLACE_CMD} -i "" -e 's:\<INSTALLTIMECOMBOPACKAGEID\>:${DISTNAME}:g' \
- ${WRKSRC}/opt/intel/${COMPILERDIR}/docs/fsupport
-.for i in ifc.orig
- @${RM} ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/${i}
+.if ${PORTVERSION} != ${PATCHLEVEL}
+ @${REINPLACE_CMD} -i "" -e \
+ 's:\<installpackageid\>:${DISTNAME}_${PATCHLEVEL}:g' \
+ ${WRKSRC}/opt/${COMPILERDIR}/doc/fsupport
+.else
+ @${REINPLACE_CMD} -i "" -e 's:\<installpackageid\>:${DISTNAME}:g' \
+ ${WRKSRC}/opt/${COMPILERDIR}/doc/fsupport
+.endif
+.for i in ifc.orig ifort.orig
+ @${RM} ${WRKSRC}/opt/${COMPILERDIR}/bin/${i}
.endfor
# Provide a more FreeBSD'ish compile environment
-.for i in ifc.cfg
- @${REINPLACE_CMD} -i "" -e 's:-Xlinker -rpath -Xlinker <INSTALLDIR>/${COMPILERDIR}/ia32/lib::g' \
- -e 's@\<INSTALLDIR\>@${PREFIX}/intel@g;' \
- ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/${i}
- @${ECHO} -e "-Qlocation,ld,${PREFIX}/intel/${COMPILERDIR}/ia32/bin/ldwrapper\n\n-Ulinux\n-U__linux__\n-U__linux\n-U__gnu_linux__\n\n-D__FreeBSD__=${IFCCFGVAL}\n-D__ELF__=1\n" >>${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/${i}
-.if ${OSVERSION} < 500016
- @${ECHO} -e "-Qoption,ld,-MT\n" >>${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/${i}
-.endif
- @${CHMOD} a-x,g-w ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/${i}
+.for i in ifc.cfg ifort.cfg
+ @${ECHO} -e "-no-gcc\n-Qlocation,ld,${PREFIX}/${COMPILERDIR}/bin/ldwrapper\n-nothreads\n\n-D__FreeBSD__=${IFCCFGVAL}\n\n" >>${WRKSRC}/opt/${COMPILERDIR}/bin/${i}
+ @${CHMOD} a-x,g-w ${WRKSRC}/opt/${COMPILERDIR}/bin/${i}
.endfor
- @cd ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/ && ${LN} -s ifc.cfg ifcbin.cfg
+ @cd ${WRKSRC}/opt/${COMPILERDIR}/bin/ && ${LN} -s ifc.cfg ifcbin.cfg \
+ && ${LN} -s ifort.cfg ifortbin.cfg
+# Remove macros for linux in ifortbin,
+# because fortcom does not accept -U option.
+ @${REINPLACE_CMD} -i "" -e 's: -Dlinux: :' \
+ -e 's: -D__linux : :' \
+ -e 's: -D__linux__ : :' \
+ -e 's: -D__gnu_linux__: :' \
+ ${WRKSRC}/opt/${COMPILERDIR}/bin/ifortbin
.if ( ${OSVERSION} >= 470101 && ${OSVERSION} < 500000 ) || \
( ${OSVERSION} >= 500042 )
-OBJCOPY_OPS= --redefine-sym stdin=__stdinp \
+OBJCOPY_OPS= --redefine-sym stdin=__stdinp \
--redefine-sym stdout=__stdoutp \
--redefine-sym stderr=__stderrp
.endif
do-build:
+# Use the Linux ABI for the binaries
+.for i in codecov fortcom fpp ifcbin ifortbin profmerge proforder tselect xiar xild
+ @${BRANDELF} -t Linux ${WRKSRC}/opt/${COMPILERDIR}/bin/${i}
+.endfor
# Fix unresolved references
@cd ${WRKSRC} && ${CC} ${CFLAGS} -c ${FILESDIR}/assert_fail.c \
${FILESDIR}/linux_file.c ${FILESDIR}/linux_stat.c \
- ${FILESDIR}/mmap.c ${FILESDIR}/pthread.c \
${FILESDIR}/sysconf.c \
${FILESDIR}/errno_location.c ${FILESDIR}/mcount.S
.if ( ${OSVERSION} < 502101 )
@@ -135,44 +160,52 @@ do-build:
@${CC} ${CFLAGS} -c -o ${WRKSRC}/stdout.o ${FILESDIR}/stdout.c
@${CC} ${CFLAGS} -c -o ${WRKSRC}/stderr.o ${FILESDIR}/stderr.c
.endif
-.for i in libcxa.a libimf.a libirc.a libircmt.a libunwind.a \
- libBINDF90.a libCEPCF90.a libF90.a libIEPCF90.a libPEPCF90.a \
- libcprts.a libintrins.a libompstub.a
+.for i in libcprts.a libcxa.a libifcore.a libifcoremt.a libifport.a libimf.a libirc.a libircmt.a libunwind.a
@${OBJCOPY} --redefine-sym __sigsetjmp=sigsetjmp \
${OBJCOPY_OPS} \
- ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/lib/${i}
+ ${WRKSRC}/opt/${COMPILERDIR}/lib/${i}
.endfor
- @cd ${WRKSRC} && ${AR} x /usr/lib/libcompat.a ftime.o
- @${AR} q ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/lib/libcxa.a ${WRKSRC}/*.o
-.for i in BINDF90 PEPCF90 CEPCF90 POSF90 IEPCF90
+.for i in ifcore ifcoremt ifport
@${OBJCOPY} --strip-symbol=stat \
--strip-symbol=fstat \
--strip-symbol=lstat \
+ --redefine-sym open=l_open \
--redefine-sym lseek=l_lseek \
- --redefine-sym lseek64=lseek \
- --redefine-sym open64=open \
- --redefine-sym creat64=creat \
- --redefine-sym ftruncate64=ftruncate \
- --redefine-sym mmap=Mmap \
- ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/lib/lib${i}.a
+ ${WRKSRC}/opt/${COMPILERDIR}/lib/lib${i}.a
+.endfor
+.for i in ifcore ifcoremt
+ @${OBJCOPY} \
+ --redefine-sym ftruncate=l_ftruncate \
+ --redefine-sym __xpg_basename=basename \
+ --redefine-sym __strtod_internal=strtod \
+ --redefine-sym __strtof_internal=strtof \
+ --redefine-sym __strtol_internal=strtol \
+ --redefine-sym __strtold_internal=strtold \
+ --redefine-sym __strtoll_internal=strtoll \
+ --redefine-sym __strtoul_internal=strtoul \
+ --redefine-sym __strtoull_internal=strtoull \
+ ${WRKSRC}/opt/${COMPILERDIR}/lib/lib${i}.a
.endfor
+ @${AR} q ${WRKSRC}/opt/${COMPILERDIR}/lib/libcxa.a ${WRKSRC}/*.o
+ @cd ${WRKSRC} && ${AR} x /usr/lib/libcompat.a ftime.o
+ @${AR} q ${WRKSRC}/opt/${COMPILERDIR}/lib/libifport.a ${WRKSRC}/ftime.o
# Some magic to be able to link
- @${MKDIR} ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/ldwrapper
+ @${MKDIR} ${WRKSRC}/opt/${COMPILERDIR}/bin/ldwrapper
@${CC} ${CFLAGS} -o \
- ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/ldwrapper/ld \
+ ${WRKSRC}/opt/${COMPILERDIR}/bin/ldwrapper/ld \
${FILESDIR}/ld.c
- @${STRIP_CMD} ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/ldwrapper/ld
- @${CHMOD} 755 ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/ldwrapper/ld
+ @${STRIP_CMD} ${WRKSRC}/opt/${COMPILERDIR}/bin/ldwrapper/ld
+ @${CHMOD} 755 ${WRKSRC}/opt/${COMPILERDIR}/bin/ldwrapper/ld
do-install:
@cd ${WRKSRC}/opt && ${FIND} . -print | \
${CPIO} -pdu -R ${BINOWN}:${BINGRP} --quiet ${PREFIX}
post-install:
- @${ECHO_CMD} "${PKGNAME} is now installed in ${PREFIX}/intel, to use it you have to"
+ @${ECHO_CMD} "${PKGNAME} is now installed in ${PREFIX}/${COMPILERDIR}, to use it you have to"
@${ECHO_CMD} "put your license into your \$${INTEL_FLEXLM_LICENSE} (default:"
- @${ECHO_CMD} "${PREFIX}/intel/licenses) directory and add"
- @${ECHO_CMD} "${PREFIX}/intel/${COMPILERDIR}/ia32/bin to your PATH."
+ @${ECHO_CMD} "${PREFIX}/${COMPILERDIR}/licenses) directory and add"
+ @${ECHO_CMD} "${PREFIX}/${COMPILERDIR}/bin to your PATH."
@${ECHO_CMD}
@${ECHO_CMD} "If you use ifc on a Pentium 4 make sure you have 'options CPU_ENABLE_SSE'"
@${ECHO_CMD} "in your kernel config (have a look at http://www.FreeBSD.org/handbook/"