aboutsummaryrefslogtreecommitdiffstats
path: root/lang/malbolge/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/malbolge/Makefile')
-rw-r--r--lang/malbolge/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/lang/malbolge/Makefile b/lang/malbolge/Makefile
new file mode 100644
index 000000000000..675c15c52164
--- /dev/null
+++ b/lang/malbolge/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: malbolge
+# Date created: 14 June 2001
+# Whom: simond@irrelevant.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= malbolge
+PORTVERSION= 1.0
+CATEGORIES= lang
+MASTER_SITES= http://www.mines.edu/students/b/bolmstea/malbolge/
+DISTNAME= malbolge
+
+MAINTAINER= simond@irrelevant.org
+
+post-patch:
+ ${PERL} -pi -e "s|<malloc.h>|<stdlib.h>|g" ${WRKSRC}/malbolge.c
+
+do-build:
+ ${CC} ${CFLAGS} ${WRKSRC}/malbolge.c -o ${WRKSRC}/malbolge
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/malbolge ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/malbolge
+ ${INSTALL_DATA} ${WRKSRC}/malbolge.txt ${PREFIX}/share/doc/malbolge
+ ${INSTALL_DATA} ${WRKSRC}/malbolge.txt ${WRKSRC}/nop.mal \
+ ${PREFIX}/share/doc/malbolge
+.endif
+
+.include <bsd.port.mk>