aboutsummaryrefslogtreecommitdiffstats
path: root/lang/p5-Marpa/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/p5-Marpa/Makefile')
-rw-r--r--lang/p5-Marpa/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/lang/p5-Marpa/Makefile b/lang/p5-Marpa/Makefile
new file mode 100644
index 000000000000..d9036bcd1f0b
--- /dev/null
+++ b/lang/p5-Marpa/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: p5-Marpa
+# Date created: 2011-10-25
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Marpa
+PORTVERSION= 0.206
+CATEGORIES= lang textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION}000
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Parse any Language You Can Describe in BNF
+
+BUILD_DEPENDS= p5-HTML-Parser>=3.64:${PORTSDIR}/www/p5-HTML-Parser \
+ p5-PPI>=1.206:${PORTSDIR}/textproc/p5-PPI
+RUN_DEPENDS= p5-HTML-Parser>=3.64:${PORTSDIR}/www/p5-HTML-Parser \
+ p5-PPI>=1.206:${PORTSDIR}/textproc/p5-PPI
+
+PERL_CONFIGURE= 5.10.0+
+
+MAN3= Marpa::Advanced::Algorithm.3 \
+ Marpa::Advanced::Bibliography.3 \
+ Marpa::Advanced::Implementation.3 \
+ Marpa::Advanced::Models.3 \
+ Marpa::Deprecated::Bocage.3 \
+ Marpa::Deprecated::Evaluator.3 \
+ Marpa::Deprecated::Implementation.3 \
+ Marpa::Grammar.3 \
+ Marpa::Marpa.3 \
+ Marpa::Parse_Terms.3 \
+ Marpa::Recognizer.3 \
+ Marpa::Semantics.3 \
+ Marpa::Support.3 \
+ Marpa::Tracing.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501200
+TEST_DEPENDS+= p5-Test-Simple>=0.94:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>