aboutsummaryrefslogtreecommitdiffstats
path: root/lang/parrot/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/parrot/Makefile')
-rw-r--r--lang/parrot/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/lang/parrot/Makefile b/lang/parrot/Makefile
index c3830d758ae6..3a46ac11d949 100644
--- a/lang/parrot/Makefile
+++ b/lang/parrot/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= parrot
-PORTVERSION= 0.4.3
-PORTREVISION= 1
+PORTVERSION= 0.4.4
CATEGORIES= lang perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= ../../authors/id/L/LT/LTOETSCH
@@ -19,8 +18,6 @@ BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4 \
icudata.34:${PORTSDIR}/devel/icu
-BROKEN= Incorrect pkg-plist
-
USE_GCC= 3.4+
USE_PERL5= yes
USE_GMAKE= yes
@@ -37,6 +34,8 @@ CONFIGURE_ARGS= --cc=${CC} --cxx=${CXX} --ld=${CC} --ccflags="${CFLAGS}" \
--prefix=${PREFIX}
# --verbose
+PLIST_SUB+= SHLIB_VER="${PORTVERSION}"
+
post-patch:
${PERL} -pi -e "s=libdir}, 'pkgconfig=prefix}, 'libdata/pkgconfig=" \
${WRKSRC}/tools/dev/install_files.pl