aboutsummaryrefslogtreecommitdiffstats
path: root/lang/php5/Makefile.ext
diff options
context:
space:
mode:
Diffstat (limited to 'lang/php5/Makefile.ext')
-rw-r--r--lang/php5/Makefile.ext6
1 files changed, 3 insertions, 3 deletions
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index 248df410681e..27b1ee61528a 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -169,7 +169,7 @@ LIB_DEPENDS+= mcve.3:${PORTSDIR}/devel/libmcve
CONFIGURE_ARGS+=--with-mcve=${LOCALBASE} \
--with-openssl-dir=${OPENSSLBASE}
-LDFLAGS+= -lcrypto -lssl
+LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
USE_OPENSSL= yes
.endif
@@ -226,7 +226,7 @@ CONFIGURE_ARGS+=--with-unixODBC=${LOCALBASE}
CONFIGURE_ARGS+=--with-openssl=${OPENSSLBASE} \
--with-openssl-dir=${OPENSSLBASE}
-LDFLAGS+= -lcrypto -lssl
+LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
USE_OPENSSL= yes
.endif
@@ -294,7 +294,7 @@ CONFIGURE_ARGS+=--with-snmp=${LOCALBASE} \
--with-openssl-dir=${OPENSSLBASE} \
--enable-ucd-snmp-hack
-LDFLAGS+= -lcrypto -lssl
+LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
USE_OPENSSL= yes
OPTIONS= SNMP4 "Use old UCD SNMP instead of the new NET SNMP" off