aboutsummaryrefslogtreecommitdiffstats
path: root/lang/php5/Makefile.ext
diff options
context:
space:
mode:
Diffstat (limited to 'lang/php5/Makefile.ext')
-rw-r--r--lang/php5/Makefile.ext50
1 files changed, 25 insertions, 25 deletions
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index 81cdd263114c..ccd55d551b79 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -32,7 +32,7 @@ CONFIGURE_ARGS+=--enable-ctype
.endif
.if ${PHP_MODNAME} == "curl"
-LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
CONFIGURE_ARGS+=--with-curl=${LOCALBASE}
.endif
@@ -86,9 +86,9 @@ USE_OPENSSL= yes
.endif
.if ${PHP_MODNAME} == "gd"
-LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2 \
- png15:${PORTSDIR}/graphics/png \
- jpeg:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg
CONFIGURE_ARGS+=--with-gd \
--with-freetype-dir=${LOCALBASE} \
@@ -115,7 +115,7 @@ USES+= gettext
.endif
.if ${PHP_MODNAME} == "gmp"
-LIB_DEPENDS+= gmp:${PORTSDIR}/math/gmp
+LIB_DEPENDS+= libgmp.so:${PORTSDIR}/math/gmp
CONFIGURE_ARGS+=--with-gmp=${LOCALBASE}
.endif
@@ -132,7 +132,7 @@ USES+= iconv
.endif
.if ${PHP_MODNAME} == "imap"
-LIB_DEPENDS+= c-client4:${PORTSDIR}/mail/cclient
+LIB_DEPENDS+= libc-client4.so:${PORTSDIR}/mail/cclient
CONFIGURE_ARGS+=--with-imap=${LOCALBASE} \
--with-pcre-dir=${LOCALBASE}
@@ -178,7 +178,7 @@ PHP_HEADER_DIRS=libmbfl libmbfl/filters libmbfl/mbfl libmbfl/nls
.endif
.if ${PHP_MODNAME} == "mcrypt"
-LIB_DEPENDS+= mcrypt:${PORTSDIR}/security/libmcrypt
+LIB_DEPENDS+= libmcrypt.so:${PORTSDIR}/security/libmcrypt
CONFIGURE_ARGS+=--with-mcrypt=${LOCALBASE}
@@ -186,7 +186,7 @@ USE_AUTOTOOLS= libltdl
.endif
.if ${PHP_MODNAME} == "mssql"
-LIB_DEPENDS+= sybdb:${PORTSDIR}/databases/freetds-msdblib
+LIB_DEPENDS+= libsybdb.so:${PORTSDIR}/databases/freetds-msdblib
CONFIGURE_ARGS+=--with-mssql=${LOCALBASE}
.endif
@@ -303,7 +303,7 @@ CONFIGURE_ARGS+=--enable-posix
.endif
.if ${PHP_MODNAME} == "pspell"
-LIB_DEPENDS+= aspell:${PORTSDIR}/textproc/aspell
+LIB_DEPENDS+= libaspell.so:${PORTSDIR}/textproc/aspell
CONFIGURE_ARGS+=--with-pspell=${LOCALBASE}
@@ -317,7 +317,7 @@ CONFIGURE_ARGS+=--with-readline=/usr
.endif
.if ${PHP_MODNAME} == "recode"
-LIB_DEPENDS+= recode:${PORTSDIR}/converters/recode
+LIB_DEPENDS+= librecode.so:${PORTSDIR}/converters/recode
CONFIGURE_ARGS+=--with-recode=${LOCALBASE}
.endif
@@ -345,7 +345,7 @@ CONFIGURE_ARGS+=--with-snmp=${LOCALBASE} \
CONFIGURE_ENV+= ac_cv_buggy_snprint_value="no"
-LIB_DEPENDS+= netsnmp:${PORTSDIR}/net-mgmt/net-snmp
+LIB_DEPENDS+= libnetsnmp.so:${PORTSDIR}/net-mgmt/net-snmp
LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
USE_OPENSSL= yes
.endif
@@ -370,7 +370,7 @@ CONFIGURE_ARGS+=--with-sqlite3=${LOCALBASE}
.endif
.if ${PHP_MODNAME} == "sybase_ct"
-LIB_DEPENDS+= ct:${PORTSDIR}/databases/freetds
+LIB_DEPENDS+= libct.so:${PORTSDIR}/databases/freetds
CONFIGURE_ARGS+=--with-sybase-ct=${LOCALBASE}
.endif
@@ -390,7 +390,7 @@ CONFIGURE_ARGS+=--enable-sysvshm
.if ${PHP_MODNAME} == "tidy"
CONFIGURE_ARGS+=--with-tidy=${LOCALBASE}
-LIB_DEPENDS+= tidy-0.99:${PORTSDIR}/www/tidy-lib
+LIB_DEPENDS+= libtidy-0.99.so:${PORTSDIR}/www/tidy-lib
.endif
.if ${PHP_MODNAME} == "tokenizer"
@@ -475,17 +475,17 @@ USE_BDB= 40+
WITH_BDB_HIGHEST= yes
. endif
. if ${PORT_OPTIONS:MGDBM}
-LIB_DEPENDS+= gdbm:${PORTSDIR}/databases/gdbm
+LIB_DEPENDS+= libgdbm.so:${PORTSDIR}/databases/gdbm
CONFIGURE_ARGS+=--with-gdbm=${LOCALBASE}
. endif
. if ${PORT_OPTIONS:MQDBM}
-LIB_DEPENDS+= qdbm:${PORTSDIR}/databases/qdbm
+LIB_DEPENDS+= libqdbm.so:${PORTSDIR}/databases/qdbm
CONFIGURE_ARGS+=--with-qdbm=${LOCALBASE}
. endif
. if ${PORT_OPTIONS:MTOKYO}
-LIB_DEPENDS+= tokyocabinet:${PORTSDIR}/databases/tokyocabinet
+LIB_DEPENDS+= libtokyocabinet.so:${PORTSDIR}/databases/tokyocabinet
CONFIGURE_ARGS+=--with-tcadb=${LOCALBASE}
. endif
@@ -499,7 +499,7 @@ CONFIGURE_ARGS+=--disable-flatfile
.if ${PHP_MODNAME} == "gd"
. if ${PORT_OPTIONS:MT1LIB}
-LIB_DEPENDS+= t1:${PORTSDIR}/devel/t1lib
+LIB_DEPENDS+= libt1.so:${PORTSDIR}/devel/t1lib
CONFIGURE_ARGS+=--with-t1lib=${LOCALBASE}
. endif
@@ -515,7 +515,7 @@ USE_XORG= xpm
CONFIGURE_ARGS+=--with-xpm-dir=${LOCALBASE}
. endif
. if ${PORT_OPTIONS:MVPX}
-LIB_DEPENDS+= vpx:${PORTSDIR}/multimedia/libvpx
+LIB_DEPENDS+= libvpx.so:${PORTSDIR}/multimedia/libvpx
CONFIGURE_ARGS+=--with-vpx-dir=${LOCALBASE}
. endif
@@ -523,7 +523,7 @@ CONFIGURE_ARGS+=--with-vpx-dir=${LOCALBASE}
.if ${PHP_MODNAME} == "mbstring"
. if ${PORT_OPTIONS:MREGEX}
-LIB_DEPENDS+= onig:${PORTSDIR}/devel/oniguruma4
+LIB_DEPENDS+= libonig.so:${PORTSDIR}/devel/oniguruma4
CONFIGURE_ARGS+=--with-onig=${LOCALBASE}
. else
CONFIGURE_ARGS+=--disable-mbregex
@@ -558,11 +558,11 @@ post-extract:
.if ${PHP_MODNAME} == "odbc"
. if ${PORT_OPTIONS:MIODBC}
-LIB_DEPENDS+= iodbc:${PORTSDIR}/databases/libiodbc
+LIB_DEPENDS+= libiodbc.so:${PORTSDIR}/databases/libiodbc
CONFIGURE_ARGS+=--with-iodbc=${LOCALBASE}
. else
-LIB_DEPENDS+= odbc:${PORTSDIR}/databases/unixODBC
+LIB_DEPENDS+= libodbc.so:${PORTSDIR}/databases/unixODBC
CONFIGURE_ARGS+=--with-unixODBC=${LOCALBASE}
. endif
@@ -570,19 +570,19 @@ CONFIGURE_ARGS+=--with-unixODBC=${LOCALBASE}
.if ${PHP_MODNAME} == "pdo_dblib"
. if ${PORT_OPTIONS:MMSSQL}
-LIB_DEPENDS+= sybdb:${PORTSDIR}/databases/freetds-msdblib
+LIB_DEPENDS+= libsybdb.so:${PORTSDIR}/databases/freetds-msdblib
. else
-LIB_DEPENDS+= ct:${PORTSDIR}/databases/freetds
+LIB_DEPENDS+= libct.so:${PORTSDIR}/databases/freetds
. endif
.endif
.if ${PHP_MODNAME} == "pdo_odbc"
. if ${PORT_OPTIONS:MIODBC}
-LIB_DEPENDS+= iodbc:${PORTSDIR}/databases/libiodbc
+LIB_DEPENDS+= libiodbc.so:${PORTSDIR}/databases/libiodbc
CONFIGURE_ARGS+=--with-pdo-odbc=iODBC,${LOCALBASE}
. else
-LIB_DEPENDS+= odbc:${PORTSDIR}/databases/unixODBC
+LIB_DEPENDS+= libodbc.so:${PORTSDIR}/databases/unixODBC
CONFIGURE_ARGS+=--with-pdo-odbc=unixODBC,${LOCALBASE}
. endif