aboutsummaryrefslogtreecommitdiffstats
path: root/lang/php5/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/php5/Makefile')
-rw-r--r--lang/php5/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index b2f71a4bf5f1..43afe764eb32 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -67,6 +67,9 @@ GNU_CONFIGURE= yes
USE_BISON= yes
USE_REINPLACE= yes
+CONFIGURE_ENV= ac_cv_pthreads_lib=${PTHREAD_LIBS} \
+ ac_cv_pthreads_cflags=${PTHREAD_CFLAGS}
+
CONFIGURE_ARGS= --enable-versioning \
--enable-memory-limit \
--with-layout=GNU \
@@ -103,7 +106,12 @@ CONFLICTS+= php4-4* php4-cli-4* mod_php4-4* php4-cgi-4*
.if defined(WITHOUT_APACHE)
.if defined(WITHOUT_CLI)
+.if defined(WITH_FASTCGI)
+CONFIGURE_ARGS+=--enable-fastcgi
+.else
CONFIGURE_ARGS+=--enable-discard-path
+.endif
+SAPI_FILE= bin/php
.else
CONFIGURE_ARGS+=--disable-cgi
.endif
@@ -124,9 +132,6 @@ PLIST_SUB+= PEAR="@comment "
MAN1= php.1
PLIST_SUB+= CLI=""
.endif
-.if defined(WITHOUT_APACHE) && defined(WITHOUT_CLI)
-SAPI_FILE= "bin/php"
-.endif
ALL_OPTIONS= BCMATH BZIP2 CALENDAR CDB CRACK CTYPE CURL DB4 DBASE DBX DIO \
DOM EXIF FILEPRO FTP GD GDBM GETTEXT GMP ICONV IMAP INTERBASE \
@@ -534,7 +539,6 @@ CONFIGURE_ARGS+=--with-zlib
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_APACHE)
-APXS?= ${LOCALBASE}/sbin/apxs
.if exists(${LOCALBASE}/include/apache2/apr.h)
WITH_APACHE2= yes
APACHE_MPM!= ${APXS} -q MPM_NAME