aboutsummaryrefslogtreecommitdiffstats
path: root/lang/php53/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/php53/Makefile')
-rw-r--r--lang/php53/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/lang/php53/Makefile b/lang/php53/Makefile
index b0354884ee5b..c3c5df8e0a28 100644
--- a/lang/php53/Makefile
+++ b/lang/php53/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= php5
-PORTVERSION= 5.2.6
-PORTREVISION?= 2
+PORTVERSION= 5.2.7
+PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP}
MASTER_SITE_SUBDIR= distributions
@@ -22,12 +22,15 @@ USE_BZIP2= yes
.if !defined(PKGNAMESUFFIX)
USE_AUTOTOOLS= autoconf:262
+LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
+
CONFIGURE_ARGS= \
--with-layout=GNU \
--with-config-file-scan-dir=${PREFIX}/etc/php \
--disable-all \
--enable-libxml \
--with-libxml-dir=${LOCALBASE} \
+ --with-pcre-regex=${LOCALBASE} \
--enable-reflection \
--program-prefix=""
@@ -55,7 +58,7 @@ MAN1= php-config.1 phpize.1
PATCH_DIST_STRIP= -p1
.if !defined(WITHOUT_SUHOSIN)
-PATCHFILES+= suhosin-patch-${PORTVERSION}-0.9.6.2.patch.gz:suhosin
+PATCHFILES+= suhosin-patch-${PORTVERSION}-0.9.6.3.patch.gz:suhosin
PATCH_SITES+= http://download.suhosin.org/:suhosin
PLIST_SUB+= SUHOSIN=""
.else
@@ -63,7 +66,8 @@ PLIST_SUB+= SUHOSIN="@comment "
.endif
.if defined(WITH_MAILHEAD)
-PATCHFILES+= php-${PORTVERSION}-mail-header.patch:mail
+#PATCHFILES+= php-${PORTVERSION}-mail-header.patch:mail
+PATCHFILES+= php-5.2.6-mail-header.patch:mail
PATCH_SITES+= http://choon.net/opensource/php/:mail
.endif
@@ -158,6 +162,10 @@ post-build:
@${ECHO_CMD} "PHP_VER=5" > ${WRKDIR}/php.conf
@${ECHO_CMD} "PHP_VERSION=${PORTVERSION}" >> ${WRKDIR}/php.conf
@${ECHO_CMD} "PHP_SAPI=${PHP_SAPI}" >> ${WRKDIR}/php.conf
+ @${ECHO_CMD} "PHP_EXT_INC=pcre" >> ${WRKDIR}/php.conf
+
+test: build
+ @(cd ${WRKSRC} && ${MAKE} test)
post-install:
@${INSTALL_DATA} ${WRKSRC}/php.ini-dist ${PREFIX}/etc