aboutsummaryrefslogtreecommitdiffstats
path: root/lang/php5
diff options
context:
space:
mode:
Diffstat (limited to 'lang/php5')
-rw-r--r--lang/php5/Makefile.ext5
1 files changed, 5 insertions, 0 deletions
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index b1836720a42e..5490e2fe2342 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -304,7 +304,12 @@ USE_PHP_BUILD= yes
.endif
.if ${PHP_MODNAME} == "pdo_sqlite"
+. if defined(WITH_SQLITE_PORT)
+USE_SQLITE= yes
+CONFIGURE_ARGS+=--with-pdo-sqlite=${LOCALBASE}
+. else
CONFIGURE_ARGS+=--with-pdo-sqlite
+. endif
USE_PHP= pdo
USE_PHP_BUILD= yes