aboutsummaryrefslogtreecommitdiffstats
path: root/lang/pypy/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/pypy/Makefile')
-rw-r--r--lang/pypy/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/lang/pypy/Makefile b/lang/pypy/Makefile
index 7f9574901904..23a0fd27c1c6 100644
--- a/lang/pypy/Makefile
+++ b/lang/pypy/Makefile
@@ -109,6 +109,9 @@ PYPY_BITS= 64
.endif
PLIST_SUB+= PYPY_BITS="${PYPY_BITS}"
+post-extract:
+ ${FIND} ${WRKSRC} -name '*.swn' -delete
+
pre-build:
if [ ! -f ${BUILD_WRKSRC}/Makefile ]; then \
${RM} -r ${WRKDIR}/build; \
@@ -156,7 +159,7 @@ pkg-plist: stage
-e '/\/$$/d' \
${WRKDIR}/.plist-files-gen
${ECHO} bin/${PORTNAME} > ${WRKDIR}/pkg-plist
- ${SORT} ${WRKDIR}/.plist-files-gen | ${GREP} -v '\.swn$$\|\.orig' >> ${WRKDIR}/pkg-plist
+ ${SORT} ${WRKDIR}/.plist-files-gen | ${GREP} -v '\.orig' >> ${WRKDIR}/pkg-plist
${CP} ${WRKDIR}/pkg-plist ${.CURDIR}/pkg-plist
.include <bsd.port.post.mk>