aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python20/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/python20/Makefile')
-rw-r--r--lang/python20/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/lang/python20/Makefile b/lang/python20/Makefile
index b1a80b319f95..6fe205d041b1 100644
--- a/lang/python20/Makefile
+++ b/lang/python20/Makefile
@@ -7,7 +7,7 @@
PORTNAME= python
PORTVERSION= 2.0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang python
MASTER_SITES= ${MASTER_SITE_PYTHON}
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION}
@@ -39,8 +39,7 @@ SETUP_FILE= Setup
# If you don't want to use Python's thread module, you need to set
# WITHOUT_THREADS.
#
-LIBC_R!= /sbin/ldconfig -r | grep c_r || true
-.if (${LIBC_R} != "") && !defined(WITHOUT_THREADS)
+.if !defined(NOLIBC_R) && !defined(WITHOUT_THREADS)
CONFIGURE_ARGS+= --with-threads
CFLAGS+= ${PTHREAD_CFLAGS}
CONFIGURE_ENV+= LDFLAGS="${PTHREAD_LIBS} ${LDFLAGS}"