aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python34/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/python34/Makefile')
-rw-r--r--lang/python34/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/lang/python34/Makefile b/lang/python34/Makefile
index eb9ee91c9e57..a33984778dad 100644
--- a/lang/python34/Makefile
+++ b/lang/python34/Makefile
@@ -3,7 +3,7 @@
PORTNAME= python34
PORTVERSION= ${PYTHON_PORTVERSION}
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
DISTNAME= Python-${PORTVERSION}
@@ -133,6 +133,17 @@ post-install:
.endif
for i in ${STAGEDIR}${PREFIX}/lib/python3.4/lib-dynload/*.so; do \
${STRIP_CMD} $$i; done # Strip shared extensions
+# This code block exists for the qemu-user enabled cross build environment.
+# When using this environment in poudriere, CC is not set to the default
+# of /usr/bin/cc and a cross-compile toolchain is used. We need to hand
+# edit this so that the run time configuration for python matches what the
+# FreeBSD base system provides. sbruno 02Aug2017
+.if ${CC} == /nxb-bin/usr/bin/cc
+ @${REINPLACE_CMD} -e 's=/nxb-bin==' \
+ ${STAGEDIR}${PREFIX}/lib/python3.4./_sysconfigdata.py
+ @${REINPLACE_CMD} -e 's=/nxb-bin==' \
+ ${STAGEDIR}${PREFIX}/lib/python3.4/config-3.4m/Makefile
+.endif
${INSTALL_DATA} ${WRKSRC}/Tools/gdb/libpython.py \
${STAGEDIR}${PREFIX}/lib/libpython3.4${ABIFLAGS}.so.1-gdb.py