aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python36
diff options
context:
space:
mode:
Diffstat (limited to 'lang/python36')
-rw-r--r--lang/python36/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/lang/python36/Makefile b/lang/python36/Makefile
index 79bf5bd09fbc..cf0a8bac59ee 100644
--- a/lang/python36/Makefile
+++ b/lang/python36/Makefile
@@ -3,7 +3,7 @@
PORTNAME= python
PORTVERSION= ${PYTHON_PORTVERSION}
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON/ftp/python/${PYTHON_PORTVERSION}
PKGNAMESUFFIX= ${PYTHON_SUFFIX}
@@ -15,7 +15,7 @@ COMMENT= Interpreted object-oriented programming language
LICENSE= PSFL
-USES= cpe ncurses pathfix pkgconfig readline ssl tar:xz shebangfix
+USES= cpe ncurses pathfix pkgconfig readline:port ssl tar:xz shebangfix
PATHFIX_MAKEFILEIN= Makefile.pre.in
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
@@ -124,6 +124,13 @@ PLIST_SUB+= NO_NIS=""
.endif
post-patch:
+# readline shared library is present on base before FreeBSD 11 - r268461
+# force setup.py ignore base and use readline from ports
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1100000
+ ${REINPLACE_CMD} -e \
+ "s|lib_dirs,\ \'readline\'|[\'${LOCALBASE}/lib\',\ \'.\'],\ \'readline\'|" \
+ ${WRKSRC}/setup.py
+.endif
${REINPLACE_CMD} -e 's|/usr/local/bin/python|${python_CMD}|' \
${WRKSRC}/Lib/cgi.py