aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ruby14/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/ruby14/Makefile')
-rw-r--r--lang/ruby14/Makefile21
1 files changed, 18 insertions, 3 deletions
diff --git a/lang/ruby14/Makefile b/lang/ruby14/Makefile
index 50189764a7ed..0f7144a7daaf 100644
--- a/lang/ruby14/Makefile
+++ b/lang/ruby14/Makefile
@@ -1,12 +1,12 @@
# New ports collection makefile for: ruby
-# Version required: 1.2.2
+# Version required: 1.2.5
# Date created: 04 September 1997
# Whom: Eiji-usagi-MATSUmoto <usagi@ruby.club.or.jp>
#
-# $Id: Makefile,v 1.8 1998/09/22 03:22:47 jkoshy Exp $
+# $Id: Makefile,v 1.9 1999/02/22 04:11:48 steve Exp $
#
-DISTNAME= ruby-1.2.2
+DISTNAME= ruby-1.2.5
CATEGORIES= lang
MASTER_SITES= ftp://ftp.netlab.co.jp/pub/lang/ruby/${BRANCH_NAME}/ \
ftp://ftp.TokyoNet.AD.JP/pub/misc/ruby/${BRANCH_NAME}/ \
@@ -17,14 +17,29 @@ MASTER_SITES= ftp://ftp.netlab.co.jp/pub/lang/ruby/${BRANCH_NAME}/ \
MAINTAINER= yasuf@big.or.jp
+WWW_SITE= http://www.netlab.co.jp/ruby/
+
GNU_CONFIGURE= yes
#USE_AUTOCONF= yes
MAN1= ruby.1
+PLIST_SUB+= RUBY_ARCH="${RUBY_ARCH}"
+
+RUBY_ARCH= ${ARCH}-freebsd${OSREL}
+
+# lib/mkmf.rb requires that the name of the install program will be
+# specified with absolute path.
+INSTALL= /usr/bin/install
BRANCH_NAME= 1.2
+post-patch:
+ ${RM} -f ${WRKSRC}/ext/tcltklib/MANIFEST
+ ${RM} -f ${WRKSRC}/ext/tk/MANIFEST
+
post-install:
strip ${PREFIX}/bin/ruby
+ ${MKDIR} ${PREFIX}/share/examples/ruby
+ ${INSTALL_DATA} ${WRKSRC}/sample/* ${PREFIX}/share/examples/ruby
test:
@(cd ${WRKSRC}; make test)