aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ruby14/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/ruby14/Makefile')
-rw-r--r--lang/ruby14/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/lang/ruby14/Makefile b/lang/ruby14/Makefile
index 21b224037935..6b555d0e88ca 100644
--- a/lang/ruby14/Makefile
+++ b/lang/ruby14/Makefile
@@ -19,9 +19,6 @@ MAINTAINER= yasuf@big.or.jp
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-shared
-.if defined(USE_INET6)
-CONFIGURE_ARGS+= --enable-ipv6
-.endif
MAN1= ruby.1
PLIST_SUB+= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
@@ -33,6 +30,12 @@ BRANCH_NAME= 1.4
DOCDIR= ${PREFIX}/share/doc/ruby
EXAMPLESDIR= ${PREFIX}/share/examples/ruby
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 400014
+CONFIGURE_ARGS+= --enable-ipv6
+.endif
+
post-patch:
${RM} -f ${WRKSRC}/ext/tcltklib/MANIFEST
${RM} -f ${WRKSRC}/ext/tk/MANIFEST
@@ -66,4 +69,4 @@ post-install:
test:
@(cd ${WRKSRC}; make test)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>