aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ruby16/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/ruby16/Makefile')
-rw-r--r--lang/ruby16/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/lang/ruby16/Makefile b/lang/ruby16/Makefile
index 65de5028227b..2c833607cc78 100644
--- a/lang/ruby16/Makefile
+++ b/lang/ruby16/Makefile
@@ -1,12 +1,12 @@
# New ports collection makefile for: ruby
-# Version required: 1.2.5
+# Version required: 1.4.0
# Date created: 04 September 1997
# Whom: Eiji-usagi-MATSUmoto <usagi@ruby.club.or.jp>
#
# $FreeBSD$
#
-DISTNAME= ruby-1.2.5
+DISTNAME= ruby-1.4.0
CATEGORIES= lang
MASTER_SITES= ftp://ftp.netlab.co.jp/pub/lang/ruby/${BRANCH_NAME}/ \
ftp://ftp.TokyoNet.AD.JP/pub/misc/ruby/${BRANCH_NAME}/ \
@@ -18,17 +18,14 @@ MASTER_SITES= ftp://ftp.netlab.co.jp/pub/lang/ruby/${BRANCH_NAME}/ \
MAINTAINER= yasuf@big.or.jp
GNU_CONFIGURE= yes
-#USE_AUTOCONF= yes
+CONFIGURE_ARGS+= --enable-shared
MAN1= ruby.1
-PLIST_SUB+= RUBY_ARCH="${RUBY_ARCH}"
+PLIST_SUB+= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
+RUBY_VER= 1.4
RUBY_ARCH= ${ARCH}-freebsd${OSREL}
-# lib/mkmf.rb requires that the name of the install program will be
-# specified with absolute path.
-INSTALL= /usr/bin/install
-
-BRANCH_NAME= 1.2
+BRANCH_NAME= .
post-patch:
${RM} -f ${WRKSRC}/ext/tcltklib/MANIFEST
@@ -38,6 +35,9 @@ post-install:
strip ${PREFIX}/bin/ruby
${MKDIR} ${PREFIX}/share/examples/ruby
${INSTALL_DATA} ${WRKSRC}/sample/* ${PREFIX}/share/examples/ruby
+ ${MKDIR} ${PREFIX}/share/examples/ruby/misc
+ ${INSTALL_DATA} ${WRKSRC}/misc/* ${PREFIX}/share/examples/ruby/misc
+ ${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
test:
@(cd ${WRKSRC}; make test)