aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ruby18/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/ruby18/Makefile')
-rw-r--r--lang/ruby18/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/lang/ruby18/Makefile b/lang/ruby18/Makefile
index baa79ab69494..2681751fbffc 100644
--- a/lang/ruby18/Makefile
+++ b/lang/ruby18/Makefile
@@ -104,12 +104,12 @@ post-extract:
${MV} ${WRKSRC}/ext/dl/h2rb ${WRKSRC}/bin/
post-patch:
- ${FIND} ${WRKSRC} -name '*.orig' -delete
+ ${FIND} ${PATCH_WRKSRC} -name '*.orig' -delete
.for d in Win32API
- ${RM} -rf ${WRKSRC}/ext/${d}
+ ${RM} -rf ${BUILD_WRKSRC}/ext/${d}
.endfor
.for d in gdbm iconv tcltklib tk
- ${MV} ${WRKSRC}/ext/${d} ${WRKDIR}/
+ ${MV} ${BUILD_WRKSRC}/ext/${d} ${WRKDIR}/
.endfor
pre-configure:
@@ -118,6 +118,7 @@ pre-configure:
./configure; \
${MAKE} -f Makefile ${RUBY_VER:S/.//} RUBYDIR=${WRKSRC}
.endif
+ ${TOUCH} ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
post-install:
.if defined(STRIP) && ${STRIP} == -s