aboutsummaryrefslogtreecommitdiffstats
path: root/lang/sather-specification/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/sather-specification/Makefile')
-rw-r--r--lang/sather-specification/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/lang/sather-specification/Makefile b/lang/sather-specification/Makefile
index 4d853cfabe66..653f73785ff7 100644
--- a/lang/sather-specification/Makefile
+++ b/lang/sather-specification/Makefile
@@ -17,11 +17,9 @@ NO_BUILD= yes
NO_WRKSUBDIR= yes
DOCSDIR= ${PREFIX}/share/doc/sather/${PORTNAME}
-NO_STAGE= yes
do-install:
- ${MKDIR} ${DOCSDIR}
- @${TAR} -xzf ${DISTDIR}/${DISTFILES} -C ${DOCSDIR}
- @${FIND} ${DOCSDIR}/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}/
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${TAR} -xzf ${DISTDIR}/${DISTFILES} -C ${STAGEDIR}${DOCSDIR}
+ @${FIND} ${STAGEDIR}${DOCSDIR}/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;
.include <bsd.port.mk>