aboutsummaryrefslogtreecommitdiffstats
path: root/lang/smarteiffel
diff options
context:
space:
mode:
Diffstat (limited to 'lang/smarteiffel')
-rw-r--r--lang/smarteiffel/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/lang/smarteiffel/Makefile b/lang/smarteiffel/Makefile
index cbd0e3a3b41c..e5a5cbfb2c30 100644
--- a/lang/smarteiffel/Makefile
+++ b/lang/smarteiffel/Makefile
@@ -30,6 +30,12 @@ PLIST_SUB+= PORTVERSION=${DISTVERSION}
SUB_FILES= pkg-install pkg-message
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 700000
+BROKEN= does not install
+.endif
+
post-patch:
@${REINPLACE_CMD} -i '' \
-e 's|^.*c_compiler_options:.*$$|c_compiler_options: ${CFLAGS}|' \
@@ -63,4 +69,4 @@ do-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>