aboutsummaryrefslogtreecommitdiffstats
path: root/lang/snobol4/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/snobol4/Makefile')
-rw-r--r--lang/snobol4/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/lang/snobol4/Makefile b/lang/snobol4/Makefile
index cacb8719185a..1fea361ac420 100644
--- a/lang/snobol4/Makefile
+++ b/lang/snobol4/Makefile
@@ -5,15 +5,24 @@
# $FreeBSD$
PORTNAME= snobol4
-PORTVERSION= 1.3
+PORTVERSION= 1.4.1
CATEGORIES= lang
MASTER_SITES= ftp://ftp.ultimate.com/snobol/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= johans@FreeBSD.org
COMMENT= A port of Macro SNOBOL4, supports full SNOBOL4 plus SPITBOL
HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX}
+CONFIGURE_ARGS= --prefix=${PREFIX} \
+ --snolibdir=${PREFIX}/lib/${PORTNAME}
USE_GMAKE= yes
+PLIST_SUB+= VERSION=${PORTVERSION}
+
+MAN1= sdb.1 snobol4.1
+MAN3= snolib.3 snobol4dbm.3 snobol4random.3 \
+ snobol4readline.3 snobol4tcl.3 snobol4time.3
+
+post-patch:
+ @${REINPLACE_CMD} 's:[^=]*\.tmp$$:${WRKSRC}/&:' ${WRKSRC}/configure
.include <bsd.port.mk>