aboutsummaryrefslogtreecommitdiffstats
path: root/lang/spidermonkey17/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/spidermonkey17/Makefile')
-rw-r--r--lang/spidermonkey17/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/lang/spidermonkey17/Makefile b/lang/spidermonkey17/Makefile
index 72a7f7b1bb60..d8b008fb37e1 100644
--- a/lang/spidermonkey17/Makefile
+++ b/lang/spidermonkey17/Makefile
@@ -16,13 +16,13 @@ LIB_DEPENDS= libnspr4.so:${PORTSDIR}/devel/nspr
CONFLICTS= njs-[0-9]*
MAKE_ARGS+= JS_THREADSAFE=YES \
- PROG_LIBS="-lreadline -ltermcap -lm -lpthread" \
+ PROG_LIBS="-lreadline -lncurses -lm -lpthread" \
LDFLAGS="-L${LOCALBASE}/lib"
CFLAGS+= -I${LOCALBASE}/include/nspr
BROKEN_sparc64= Does not build on sparc64: fails to link
-USES= gmake readline
+USES= gmake ncurses readline
MAKEFILE= Makefile.ref
ALL_TARGET= ${OPSYS}`${UNAME} -r`_DBG.OBJ/js
MAKE_ENV+= CCC="${CXX}"