aboutsummaryrefslogtreecommitdiffstats
path: root/lang/squeak3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/squeak3/Makefile')
-rw-r--r--lang/squeak3/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/lang/squeak3/Makefile b/lang/squeak3/Makefile
new file mode 100644
index 000000000000..b04d84867318
--- /dev/null
+++ b/lang/squeak3/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: squeak
+# Version required: 1.18
+# Date created: 25 April 1997
+# Whom: jesse
+#
+# $Id$
+#
+
+DISTNAME= Squeak-1.18
+PKGNAME= squeak-1.18
+CATEGORIES= lang
+MASTER_SITES= ftp://ftp.cs.uni-magdeburg.de/pub/fbsd/
+
+MAINTAINER= jesse@cs.uni-magdeburg.de
+
+WRKSRC= $(WRKDIR)/Squeak-1.18/src
+
+do-install:
+ ${INSTALL_PROGRAM} $(WRKSRC)/SqueakVM $(PREFIX)/bin
+ ${MKDIR} $(PREFIX)/share/squeak
+ ${INSTALL_DATA} $(WRKSRC)/../image/SqueakV1.sources $(PREFIX)/share/squeak
+ ${INSTALL_DATA} $(WRKSRC)/../image/Squeak1.18.image $(PREFIX)/share/squeak
+ ${INSTALL_DATA} $(WRKSRC)/../image/Squeak1.18.changes $(PREFIX)/share/squeak
+
+.include <bsd.port.mk>