aboutsummaryrefslogtreecommitdiffstats
path: root/lang/stklos/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/stklos/Makefile')
-rw-r--r--lang/stklos/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/lang/stklos/Makefile b/lang/stklos/Makefile
index 07011c909f31..fd5c4076aeef 100644
--- a/lang/stklos/Makefile
+++ b/lang/stklos/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= stklos
-PORTVERSION= 1.01
+PORTVERSION= 1.10
CATEGORIES= lang scheme
MASTER_SITES= http://www.stklos.net/download/ \
ftp://kaolin.essi.fr/pub/STklos/
@@ -17,7 +17,7 @@ COMMENT= The successor of the STk Scheme interpreter
LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
pcre.0:${PORTSDIR}/devel/pcre \
ffi.5:${PORTSDIR}/devel/libffi \
- gc.1:${PORTSDIR}/devel/boehm-gc-threaded
+ gc-threaded.1:${PORTSDIR}/devel/boehm-gc-threaded
ONLY_FOR_ARCHS= i386 amd64
@@ -47,6 +47,9 @@ post-patch:
-e 's|-@VERSION@||' \
-e 's|^man_MANS = |man_MANS = stklos-pkg.1 |' \
${WRKSRC}/doc/Makefile.in
+ @${REINPLACE_CMD} -e 's|; make|; $$(MAKE)|' \
+ ${WRKSRC}/doc/Makefile.in ${WRKSRC}/doc/Makefile.am \
+ ${WRKSRC}/lib/Makefile.in ${WRKSRC}/lib/Makefile.am
.if defined(NOPORTDOCS)
@${REINPLACE_CMD} -E -e 's/^(install-data-am:).*/\1 install-man install-schemeDATA/' \
@@ -54,4 +57,8 @@ post-patch:
${WRKSRC}/doc/Makefile.in
.endif
+regression-test: build
+ (cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} \
+ ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} test)
+
.include <bsd.port.post.mk>