aboutsummaryrefslogtreecommitdiffstats
path: root/lang/tclplugin/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/tclplugin/Makefile')
-rw-r--r--lang/tclplugin/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/lang/tclplugin/Makefile b/lang/tclplugin/Makefile
index 7295f5a13360..5b8d9d59de43 100644
--- a/lang/tclplugin/Makefile
+++ b/lang/tclplugin/Makefile
@@ -3,25 +3,28 @@
# Date created: Sat Nov 8 10:46:42 CET 1997
# Whom: andreas
#
-# $Id: Makefile,v 1.4 1997/11/15 23:58:33 andreas Exp $
+# $Id: Makefile,v 1.5 1997/12/07 00:46:30 vanilla Exp $
#
-DISTNAME= tclplugin2.0.4-beta
-PKGNAME= tclplugin-2.0.4b
+DISTNAME= tclplug20b5-src
+PKGNAME= tclplugin-2.05b
CATEGORIES= lang
MASTER_SITES= ftp://ftp.sunlabs.com/pub/tcl/plugin/
MAINTAINER= andreas@FreeBSD.ORG
-BUILD_DEPENDS= /nonexistent:${PORTSDIR}/lang/tcl80:build \
- /nonexistent:${PORTSDIR}/x11/tk80:build
RUN_DEPENDS= netscape:${PORTSDIR}/www/netscape4-communicator
+BROKEN= "here TCL Plugin is only recognized when running as root"
NO_PACKAGE= yes
-WRKSRC= ${WRKDIR}/${DISTNAME}/unix
+WRKSRC= ${WRKDIR}/tclplugin2.0b5/plugin2.0/unix
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-tcl=${PORTSDIR}/lang/tcl80/work/tcl8.0/unix \
- --with-tk=${PORTSDIR}/x11/tk80/work/tk8.0/unix \
+CONFIGURE_ARGS= --with-tcl=${WRKDIR}/tclplugin2.0b5/tcl8.0/unix \
+ --with-tk=${WRKDIR}/tclplugin2.0b5/tk8.0/unix \
--with-mozilla=${PREFIX}/lib/netscape
+pre-configure:
+ ( cd ${WRKDIR}/tclplugin2.0b5/tcl8.0/unix; ./configure --enable-shared )
+ ( cd ${WRKDIR}/tclplugin2.0b5/tk8.0/unix; ./configure --enable-shared )
+
.include <bsd.port.mk>