aboutsummaryrefslogtreecommitdiffstats
path: root/lang/tinycobol
diff options
context:
space:
mode:
Diffstat (limited to 'lang/tinycobol')
-rw-r--r--lang/tinycobol/Makefile13
-rw-r--r--lang/tinycobol/distinfo4
-rw-r--r--lang/tinycobol/files/patch-aa11
-rw-r--r--lang/tinycobol/files/patch-ab11
-rw-r--r--lang/tinycobol/files/patch-compiler_scan.l18
-rw-r--r--lang/tinycobol/pkg-plist6
6 files changed, 27 insertions, 36 deletions
diff --git a/lang/tinycobol/Makefile b/lang/tinycobol/Makefile
index 03243fbb1458..9db885f3e99a 100644
--- a/lang/tinycobol/Makefile
+++ b/lang/tinycobol/Makefile
@@ -6,15 +6,15 @@
#
PORTNAME= tinycobol
-PORTVERSION= 0.61
+PORTVERSION= 0.62
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= tiny-cobol
-MAINTAINER= ports@freebsd.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= A tiny COBOL compiler for IA32 platforms
-LIB_DEPENDS= db2.0:${PORTSDIR}/databases/db2
+LIB_DEPENDS= db3:${PORTSDIR}/databases/db3
INSTALLS_SHLIB= yes
ONLY_FOR_ARCHS= i386
@@ -23,16 +23,13 @@ HAS_CONFIGURE= yes
USE_BISON= yes
USE_GMAKE= yes
-CONFIGURE_ARGS= --with-libdb=2
-# --with-readline disabled because of CPP-clash between readline/chardefs.h
-# and htcobol.tab.h:PAGE/RETURN/ALPHABETIC
-#CONFIGURE_ARGS+= --with-readline
+CONFIGURE_ARGS= --with-libdb=3 --with-readline
CPPFLAGS= -I${LOCALBASE}/include
CFLAGS= ${CPPFGLAGS}
LDFLAGS= -L${LOCALBASE}/lib
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
-MAN1= htcobol.1 htcobf2f.1 htcobolpp.1
+MAN1= htcobol.1 htcobf2f.1
post-install:
.if !defined(NOPORTDOCS)
diff --git a/lang/tinycobol/distinfo b/lang/tinycobol/distinfo
index 837d4738a0df..9f078d16cbc5 100644
--- a/lang/tinycobol/distinfo
+++ b/lang/tinycobol/distinfo
@@ -1,2 +1,2 @@
-MD5 (tinycobol-0.61.tar.gz) = d9b5c00a2407ab8b42689a7d21c62af2
-SIZE (tinycobol-0.61.tar.gz) = 817294
+MD5 (tinycobol-0.62.tar.gz) = ba75acd052891b58db282729e38645fc
+SIZE (tinycobol-0.62.tar.gz) = 835871
diff --git a/lang/tinycobol/files/patch-aa b/lang/tinycobol/files/patch-aa
deleted file mode 100644
index cb987fee6cc3..000000000000
--- a/lang/tinycobol/files/patch-aa
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig Fri Mar 5 11:33:30 2004
-+++ configure Fri Mar 5 11:33:43 2004
-@@ -698,7 +698,7 @@
- curses_header='ncurses.h'
- curses_library='ncurses'
- LIBS="-L/usr/lib $M_LIBS"
--INCLUDES="-I/usr/include -I../lib -I../"
-+INCLUDES="-I/usr/include -I/usr/local/include -I../lib -I../"
-
- # Check for executable suffix
- # Set include and libraries paths
diff --git a/lang/tinycobol/files/patch-ab b/lang/tinycobol/files/patch-ab
deleted file mode 100644
index fcaae736cd8e..000000000000
--- a/lang/tinycobol/files/patch-ab
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/Makefile.in.orig Sun Oct 20 04:37:38 2002
-+++ lib/Makefile.in Tue Nov 5 16:29:57 2002
-@@ -28,7 +28,7 @@
- GREP = grep -v
-
- MAKEDEPEND=@MAKEDEPEND@
--LIBS=-ldl @htg_ld_args_m@ @htg_ld_args_db@ -lncurses
-+LIBS=-L/usr/local/lib @htg_ld_args_m@ @htg_ld_args_db@ -lncurses
- #
- # Default install directory is set in htconfig.h
- #
diff --git a/lang/tinycobol/files/patch-compiler_scan.l b/lang/tinycobol/files/patch-compiler_scan.l
new file mode 100644
index 000000000000..e43424664d98
--- /dev/null
+++ b/lang/tinycobol/files/patch-compiler_scan.l
@@ -0,0 +1,18 @@
+--- compiler/scan.l.orig Tue Nov 23 04:47:01 2004
++++ compiler/scan.l Thu Apr 14 18:46:07 2005
+@@ -24,7 +24,6 @@
+ */
+
+ %{
+-#include "htcoblib.h"
+ #include "htglobals.h"
+ #include <ctype.h>
+
+@@ -91,6 +90,7 @@
+
+ #include "htcoboly.h"
+ #include "htcobol.tab.h" /* definitions from YACC */
++#include "htcoblib.h"
+ #include "reswords.h"
+
+ #define TOKTEXT_SIZE 1024
diff --git a/lang/tinycobol/pkg-plist b/lang/tinycobol/pkg-plist
index 544fd265bd3c..54745a65e559 100644
--- a/lang/tinycobol/pkg-plist
+++ b/lang/tinycobol/pkg-plist
@@ -1,9 +1,7 @@
bin/htcobol
+lib/libhtcobol.a
share/htcobol/htcobolrc
-lib/libhtcobol.so.0.61.0
-lib/libhtcobol.so
-lib/libhtcobol.so.0
-share/htcobol/htcobolpp
+share/htcobol/htrtconf
share/htcobol/copybooks/screen.cpy
%%PORTDOCS%%%%DOCSDIR%%/Comments.old.txt
%%PORTDOCS%%%%DOCSDIR%%/Compiler-Overview.txt