aboutsummaryrefslogtreecommitdiffstats
path: root/lang/v8-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/v8-devel/Makefile')
-rw-r--r--lang/v8-devel/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/lang/v8-devel/Makefile b/lang/v8-devel/Makefile
index c492f22b9400..4e3d6d3288b8 100644
--- a/lang/v8-devel/Makefile
+++ b/lang/v8-devel/Makefile
@@ -38,9 +38,12 @@ MAKE_ARGS+= clang=on
MAKE_ENV+= LINK=clang++ AR=/usr/bin/ar
.if ${COMPILER_VERSION} >= 33
CFLAGS+= -Wno-nested-anon-types -Wno-unused-function
-.endif
.if ${COMPILER_VERSION} >= 34
CFLAGS+= -Wno-unused-const-variable
+.if ${COMPILER_VERSION} >= 35
+CFLAGS+= -Wno-tautological-undefined-compare
+.endif
+.endif
.endif
.else
MAKE_ARGS+= strictaliasing=off