aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
Diffstat (limited to 'lang')
-rw-r--r--lang/rexx-wrapper/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/lang/rexx-wrapper/Makefile b/lang/rexx-wrapper/Makefile
index e080a276f5fe..86a4eba75af3 100644
--- a/lang/rexx-wrapper/Makefile
+++ b/lang/rexx-wrapper/Makefile
@@ -23,4 +23,12 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-rexx=regina
DATADIR= ${PREFIX}/share/rexx${PORTNAME}
+post-patch: .SILENT
+ @${REINPLACE_CMD} -Ee "/^compiler\.unix/s,'.*','${CC:T}'," \
+ -e "s,cc\.cc = .*,cc.${CC:T} = '${CC}'," \
+ -e "/ opt/s/-[Og][^' ]?//" \
+ -e "s,cflags\. = '(.*)',cflags. = '\1 ${CFLAGS}'," \
+ ${WRKSRC}/rexxwrap.cmd
+ @${REINPLACE_CMD} 's/-compiler=$$(CC/&:T/' ${WRKSRC}/Makefile.in
+
.include <bsd.port.mk>