aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
Diffstat (limited to 'lang')
-rw-r--r--lang/erlang/Makefile4
-rw-r--r--lang/erlang14/Makefile4
-rw-r--r--lang/fpc/Makefile.units2
-rw-r--r--lang/php4/Makefile.ext2
-rw-r--r--lang/php5/Makefile.ext4
-rw-r--r--lang/php52/Makefile.ext4
-rw-r--r--lang/php53/Makefile.ext4
-rw-r--r--lang/pike76/Makefile4
-rw-r--r--lang/swi-pl/Makefile1
9 files changed, 15 insertions, 14 deletions
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index e6f0b9add2b8..105c71e8844f 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -7,7 +7,7 @@
PORTNAME= erlang
PORTVERSION= r14b04
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= lang parallel java
MASTER_SITES= http://www.erlang.org/download/:erlangorg \
@@ -91,7 +91,7 @@ USE_GCC= 4.2+
.if !defined(WITHOUT_ODBC)
DRIVER_MANAGER?= iodbc
.if ${DRIVER_MANAGER} == "unixodbc"
-LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
+LIB_DEPENDS+= odbc.2:${PORTSDIR}/databases/unixODBC
.else # assume we're using iodbc
LIB_DEPENDS+= iodbc.3:${PORTSDIR}/databases/libiodbc
.endif
diff --git a/lang/erlang14/Makefile b/lang/erlang14/Makefile
index e6f0b9add2b8..105c71e8844f 100644
--- a/lang/erlang14/Makefile
+++ b/lang/erlang14/Makefile
@@ -7,7 +7,7 @@
PORTNAME= erlang
PORTVERSION= r14b04
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= lang parallel java
MASTER_SITES= http://www.erlang.org/download/:erlangorg \
@@ -91,7 +91,7 @@ USE_GCC= 4.2+
.if !defined(WITHOUT_ODBC)
DRIVER_MANAGER?= iodbc
.if ${DRIVER_MANAGER} == "unixodbc"
-LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
+LIB_DEPENDS+= odbc.2:${PORTSDIR}/databases/unixODBC
.else # assume we're using iodbc
LIB_DEPENDS+= iodbc.3:${PORTSDIR}/databases/libiodbc
.endif
diff --git a/lang/fpc/Makefile.units b/lang/fpc/Makefile.units
index ce0748a26af8..9b2cc9287233 100644
--- a/lang/fpc/Makefile.units
+++ b/lang/fpc/Makefile.units
@@ -37,7 +37,7 @@ USE_MYSQL= yes
.if ${PKGNAMESUFFIX} == "-odbc"
. if defined(WITH_ODBC)
-LIB_DEPENDS= odbc.1:${PORTSDIR}/databases/unixODBC
+LIB_DEPENDS= odbc.2:${PORTSDIR}/databases/unixODBC
. endif
.endif
diff --git a/lang/php4/Makefile.ext b/lang/php4/Makefile.ext
index d6489c705a2b..3819c1549360 100644
--- a/lang/php4/Makefile.ext
+++ b/lang/php4/Makefile.ext
@@ -217,7 +217,7 @@ CONFIGURE_ARGS+=--with-ncurses=/usr
.endif
.if ${PHP_MODNAME} == "odbc"
-LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
+LIB_DEPENDS+= odbc.2:${PORTSDIR}/databases/unixODBC
CONFIGURE_ARGS+=--with-unixODBC=${LOCALBASE}
.endif
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index 45878e639b21..4e36f7238835 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -534,7 +534,7 @@ LIB_DEPENDS+= iodbc.3:${PORTSDIR}/databases/libiodbc
CONFIGURE_ARGS+=--with-iodbc=${LOCALBASE}
.else
-LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
+LIB_DEPENDS+= odbc.2:${PORTSDIR}/databases/unixODBC
CONFIGURE_ARGS+=--with-unixODBC=${LOCALBASE}
.endif
@@ -554,7 +554,7 @@ LIB_DEPENDS+= iodbc.3:${PORTSDIR}/databases/libiodbc
CONFIGURE_ARGS+=--with-pdo-odbc=iODBC,${LOCALBASE}
.else
-LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
+LIB_DEPENDS+= odbc.2:${PORTSDIR}/databases/unixODBC
CONFIGURE_ARGS+=--with-pdo-odbc=unixODBC,${LOCALBASE}
.endif
diff --git a/lang/php52/Makefile.ext b/lang/php52/Makefile.ext
index 03658932796b..93dcd8e89db0 100644
--- a/lang/php52/Makefile.ext
+++ b/lang/php52/Makefile.ext
@@ -232,7 +232,7 @@ CONFIGURE_ARGS+=--with-oci8=${LOCALBASE}/oracle8-client
.endif
.if ${PHP_MODNAME} == "odbc"
-LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
+LIB_DEPENDS+= odbc.2:${PORTSDIR}/databases/unixODBC
CONFIGURE_ARGS+=--with-unixODBC=${LOCALBASE}
.endif
@@ -296,7 +296,7 @@ USE_PHP_BUILD= yes
.endif
.if ${PHP_MODNAME} == "pdo_odbc"
-LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
+LIB_DEPENDS+= odbc.2:${PORTSDIR}/databases/unixODBC
CONFIGURE_ARGS+=--with-pdo-odbc=unixODBC,${LOCALBASE}
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index 45878e639b21..4e36f7238835 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -534,7 +534,7 @@ LIB_DEPENDS+= iodbc.3:${PORTSDIR}/databases/libiodbc
CONFIGURE_ARGS+=--with-iodbc=${LOCALBASE}
.else
-LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
+LIB_DEPENDS+= odbc.2:${PORTSDIR}/databases/unixODBC
CONFIGURE_ARGS+=--with-unixODBC=${LOCALBASE}
.endif
@@ -554,7 +554,7 @@ LIB_DEPENDS+= iodbc.3:${PORTSDIR}/databases/libiodbc
CONFIGURE_ARGS+=--with-pdo-odbc=iODBC,${LOCALBASE}
.else
-LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
+LIB_DEPENDS+= odbc.2:${PORTSDIR}/databases/unixODBC
CONFIGURE_ARGS+=--with-pdo-odbc=unixODBC,${LOCALBASE}
.endif
diff --git a/lang/pike76/Makefile b/lang/pike76/Makefile
index 5fa794c28f55..5bea760ef0b0 100644
--- a/lang/pike76/Makefile
+++ b/lang/pike76/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pike76
PORTVERSION= 7.6.112
-PORTREVISION= 13
+PORTREVISION= 14
CATEGORIES= lang
MASTER_SITES= ftp://pike.ida.liu.se/pub/pike/beta/${PORTVERSION}/ \
http://pike.ida.liu.se/pub/pike/beta/${PORTVERSION}/ \
@@ -170,7 +170,7 @@ CONFIGURE_ARGS+= --without-msql
.endif
.if defined(WITH_UNIXODBC)
-LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
+LIB_DEPENDS+= odbc.2:${PORTSDIR}/databases/unixODBC
CONFIGURE_ARGS+= --with-odbc
.endif
diff --git a/lang/swi-pl/Makefile b/lang/swi-pl/Makefile
index 680be6089fea..bd38f6bcd8e3 100644
--- a/lang/swi-pl/Makefile
+++ b/lang/swi-pl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= swi-pl
PORTVERSION= 5.10.5
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= http://www.swi-prolog.org/download/stable/src/
DISTNAME= pl-${PORTVERSION}