aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
Diffstat (limited to 'lang')
-rw-r--r--lang/php_doc/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/lang/php_doc/Makefile b/lang/php_doc/Makefile
index dd2376bde9b4..071afa4d0e7d 100644
--- a/lang/php_doc/Makefile
+++ b/lang/php_doc/Makefile
@@ -41,13 +41,13 @@ pre-fetch:
.endif
pre-install:
- ${FIND} ${WRKDIR} -type f ! -name '.*' | ${SED} -e "s,${WRKDIR},%%PHPDOCDIR%%," > ${PLIST}
+ ${FIND} ${WRKDIR} -type f ! -name '.*' ! -name pkg-plist | ${SED} -e "s,${WRKDIR},%%PHPDOCDIR%%," > ${PLIST}
${FIND} ${WRKDIR} -type d | ${SORT} -r | ${SED} -e "s,${WRKDIR},@dirrm %%PHPDOCDIR%%," >> ${PLIST}
do-install:
@${MKDIR} ${PHPDOCDIR}
${FIND} ${WRKDIR} -type d | ${SED} -e "s,${WRKDIR},${PHPDOCDIR}/," | ${XARGS} ${MKDIR}
- for f in `${FIND} ${WRKDIR} -type f ! -name '.*' | ${SED} -e "s,${WRKDIR}/,,"`; do \
+ for f in `${FIND} ${WRKDIR} -type f ! -name '.*' ! -name pkg-plist | ${SED} -e "s,${WRKDIR}/,,"`; do \
${INSTALL_DATA} ${WRKDIR}/$$f ${PHPDOCDIR}/$$f; \
done