aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile3
-rw-r--r--lang/ruby-extensions/Makefile50
-rw-r--r--lang/ruby-extensions/distinfo2
-rw-r--r--lang/ruby-extensions/pkg-descr7
-rw-r--r--lang/ruby-extensions/pkg-plist64
-rw-r--r--lang/ruby-lua/Makefile43
-rw-r--r--lang/ruby-lua/distinfo2
-rw-r--r--lang/ruby-lua/pkg-descr9
-rw-r--r--lang/ruby-lua/pkg-plist3
-rw-r--r--lang/ruby-perl/Makefile58
-rw-r--r--lang/ruby-perl/distinfo2
-rw-r--r--lang/ruby-perl/files/patch-perl.c47
-rw-r--r--lang/ruby-perl/pkg-descr6
-rw-r--r--lang/ruby-perl/pkg-plist16
14 files changed, 0 insertions, 312 deletions
diff --git a/lang/Makefile b/lang/Makefile
index d69a923f8dea..bcedfed39597 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -287,12 +287,9 @@
SUBDIR += rscheme
SUBDIR += rubinius
SUBDIR += ruby-doc-stdlib
- SUBDIR += ruby-extensions
- SUBDIR += ruby-lua
SUBDIR += ruby-lua4
SUBDIR += ruby-man
SUBDIR += ruby-mode.el
- SUBDIR += ruby-perl
SUBDIR += ruby-programmingruby
SUBDIR += ruby-reference
SUBDIR += ruby-usersguide
diff --git a/lang/ruby-extensions/Makefile b/lang/ruby-extensions/Makefile
deleted file mode 100644
index 8977a814e698..000000000000
--- a/lang/ruby-extensions/Makefile
+++ /dev/null
@@ -1,50 +0,0 @@
-# New ports collection makefile for: ruby-extensions
-# Date created: 3 Jan 2007
-# Whom: Christopher Boumenot <boumenot@gmail.com>
-#
-# $FreeBSD$
-#
-
-PORTNAME= extensions
-PORTVERSION= 0.6.0
-CATEGORIES= lang ruby
-MASTER_SITES= RF
-PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
-EXTRACT_SUFX= .tgz
-DIST_SUBDIR= ruby
-
-MAINTAINER= ruby@FreeBSD.org
-COMMENT= Useful extensions for Ruby's standard classes
-
-DEPRECATED= Doesn't work with Ruby 1.9
-EXPIRATION_DATE= 2011-08-03
-
-RUBY_SETUP= install.rb
-USE_RUBY= yes
-USE_RUBY_SETUP= yes
-USE_RUBY_RDOC= yes
-
-.if !defined(NOPORTDOCS)
-USE_RAKE= yes
-.endif
-
-DOCS_EN= README README.1st build/rdoc/*
-
-post-build:
-.if !defined(NOPORTDOCS)
- cd ${WRKSRC} && ${RAKE_BIN} rerdoc
-.endif
-
-post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${RUBY_MODDOCDIR}
-.for f in ${DOCS_EN}
- ${CP} -R ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
-.endfor
-.endif
-
-.include <bsd.port.pre.mk>
-.if ${RUBY_VER} == 1.9
-BROKEN= does not build with ruby 1.9
-.endif
-.include <bsd.port.post.mk>
diff --git a/lang/ruby-extensions/distinfo b/lang/ruby-extensions/distinfo
deleted file mode 100644
index 5cd7cb7345dd..000000000000
--- a/lang/ruby-extensions/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (ruby/extensions-0.6.0.tgz) = 54cb19d24178e00ace56b0f15e8183d0c1ec09fd73843666ccd6cd1d3a584369
-SIZE (ruby/extensions-0.6.0.tgz) = 43432
diff --git a/lang/ruby-extensions/pkg-descr b/lang/ruby-extensions/pkg-descr
deleted file mode 100644
index 6a72acc22212..000000000000
--- a/lang/ruby-extensions/pkg-descr
+++ /dev/null
@@ -1,7 +0,0 @@
-This project defines various useful extensions to Ruby's standard classes,
-including many of those captured at on the Wiki at StandardClassExtensions.
-They are thoroughly documented and tested. See the project homepage for API
-documentation.
-
-Author: Gavin Sinclair <gsinclair@soyabean.com.au>
-WWW: http://extensions.rubyforge.net
diff --git a/lang/ruby-extensions/pkg-plist b/lang/ruby-extensions/pkg-plist
deleted file mode 100644
index 32cd81d56715..000000000000
--- a/lang/ruby-extensions/pkg-plist
+++ /dev/null
@@ -1,64 +0,0 @@
-bin/rbxtm
-%%RUBY_SITELIBDIR%%/extensions/_base.rb
-%%RUBY_SITELIBDIR%%/extensions/_template.rb
-%%RUBY_SITELIBDIR%%/extensions/all.rb
-%%RUBY_SITELIBDIR%%/extensions/array.rb
-%%RUBY_SITELIBDIR%%/extensions/binding.rb
-%%RUBY_SITELIBDIR%%/extensions/class.rb
-%%RUBY_SITELIBDIR%%/extensions/continuation.rb
-%%RUBY_SITELIBDIR%%/extensions/enumerable.rb
-%%RUBY_SITELIBDIR%%/extensions/hash.rb
-%%RUBY_SITELIBDIR%%/extensions/io.rb
-%%RUBY_SITELIBDIR%%/extensions/kernel.rb
-%%RUBY_SITELIBDIR%%/extensions/module.rb
-%%RUBY_SITELIBDIR%%/extensions/numeric.rb
-%%RUBY_SITELIBDIR%%/extensions/object.rb
-%%RUBY_SITELIBDIR%%/extensions/ostruct.rb
-%%RUBY_SITELIBDIR%%/extensions/string.rb
-%%RUBY_SITELIBDIR%%/extensions/symbol.rb
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README.1st
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/files/lib/extensions/_template_rb.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/files/lib/extensions/array_rb.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/files/lib/extensions/binding_rb.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/files/lib/extensions/class_rb.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/files/lib/extensions/continuation_rb.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/files/lib/extensions/enumerable_rb.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/files/lib/extensions/hash_rb.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/files/lib/extensions/io_rb.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/files/lib/extensions/kernel_rb.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/files/lib/extensions/module_rb.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/files/lib/extensions/numeric_rb.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/files/lib/extensions/object_rb.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/files/lib/extensions/ostruct_rb.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/files/lib/extensions/string_rb.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/files/lib/extensions/symbol_rb.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/files/lib/extensions/_base_rb.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/files/lib/extensions/all_rb.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/files/README.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/classes/Enumerable.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/classes/Symbol.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/classes/Array.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/classes/Module.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/classes/Continuation.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/classes/Numeric.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/classes/IO.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/classes/Class.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/classes/OpenStruct.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/classes/Object.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/classes/Binding.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/classes/String.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/classes/Kernel.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/classes/Integer.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/fr_method_index.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/fr_file_index.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/rdoc-style.css
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/created.rid
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/fr_class_index.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/index.html
-@dirrm %%RUBY_SITELIBDIR%%/extensions
-@dirrm %%PORTDOCS%%%%RUBY_MODDOCDIR%%/files/lib/extensions
-@dirrm %%PORTDOCS%%%%RUBY_MODDOCDIR%%/files/lib
-@dirrm %%PORTDOCS%%%%RUBY_MODDOCDIR%%/files
-@dirrm %%PORTDOCS%%%%RUBY_MODDOCDIR%%/classes
-@dirrm %%PORTDOCS%%%%RUBY_MODDOCDIR%%
diff --git a/lang/ruby-lua/Makefile b/lang/ruby-lua/Makefile
deleted file mode 100644
index 43687de8d303..000000000000
--- a/lang/ruby-lua/Makefile
+++ /dev/null
@@ -1,43 +0,0 @@
-# New ports collection makefile for: Ruby/Lua5
-# Date created: 30 August 2001
-# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= lua5
-PORTVERSION= 0.2.2
-PORTEPOCH= 1
-CATEGORIES= lang ruby
-MASTER_SITES= http://www.moonwolf.com/ruby/archive/
-PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
-DISTNAME= rub-${PORTNAME}-${PORTVERSION}
-DIST_SUBDIR= ruby
-
-MAINTAINER= ruby@FreeBSD.org
-COMMENT= A Ruby extension to make Lua script language as a class
-
-DEPRECATED= Doesn't work with Ruby 1.9
-EXPIRATION_DATE= 2011-08-03
-
-USE_LUA= 5.0
-USE_RUBY= yes
-USE_RUBY_SETUP= yes
-RUBY_SETUP= install.rb
-CONFIGURE_ARGS= -- --with-lua-include=${LUA_INCDIR} --with-lua-lib=${LUA_LIBDIR}
-
-post-patch:
- @${REINPLACE_CMD} -e 's|\(create_makefile("lua\)")|\1-${LUA_VER}")|' \
- ${WRKSRC}/ext/lua/extconf.rb
-
-post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${RUBY_MODDOCDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${RUBY_MODDOCDIR}
-.endif
-
-.include <bsd.port.pre.mk>
-.if ${RUBY_VER} == 1.9
-BROKEN= does not build with ruby 1.9
-.endif
-.include <bsd.port.post.mk>
diff --git a/lang/ruby-lua/distinfo b/lang/ruby-lua/distinfo
deleted file mode 100644
index 72beb5fed7fb..000000000000
--- a/lang/ruby-lua/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (ruby/rub-lua5-0.2.2.tar.gz) = 4861fa75b990620443604cea9dbb605e05d27b9cc136a66bb5eaf051cdf96ea5
-SIZE (ruby/rub-lua5-0.2.2.tar.gz) = 11267
diff --git a/lang/ruby-lua/pkg-descr b/lang/ruby-lua/pkg-descr
deleted file mode 100644
index 0a2ef5feb5c0..000000000000
--- a/lang/ruby-lua/pkg-descr
+++ /dev/null
@@ -1,9 +0,0 @@
-Ruby-Lua -- an embebed scripting language for ruby programs
-
-This is a first attempt to make Lua script language as a class for
-ruby, it's very basic right now.
-
-Author: Domingo Alvarez <domingo@dad-it.com>,
- MoonWolf <moonwolf@moonwolf.com>
-WWW: http://ruby-lua.unolotiene.com/
- http://raa.ruby-lang.org/list.rhtml?name=rub-lua5
diff --git a/lang/ruby-lua/pkg-plist b/lang/ruby-lua/pkg-plist
deleted file mode 100644
index 2cc3aa971126..000000000000
--- a/lang/ruby-lua/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-%%RUBY_SITEARCHLIBDIR%%/lua-%%LUA_VER%%.so
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
-%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%
diff --git a/lang/ruby-perl/Makefile b/lang/ruby-perl/Makefile
deleted file mode 100644
index d26c217a9c96..000000000000
--- a/lang/ruby-perl/Makefile
+++ /dev/null
@@ -1,58 +0,0 @@
-# New ports collection makefile for: Ruby-perl
-# Date created: 11 Aug 2000
-# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= perl
-PORTVERSION= 0.2.9
-CATEGORIES= lang ruby perl5
-MASTER_SITES= http://www.yoshidam.net/
-PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
-DIST_SUBDIR= ruby
-
-MAINTAINER= ruby@FreeBSD.org
-COMMENT= A Ruby extension module to use the functions of Perl from Ruby
-
-DEPRECATED= Doesn't work with Ruby 1.9
-EXPIRATION_DATE= 2011-08-03
-
-USE_PERL5= yes
-USE_RUBY= yes
-USE_RUBY_EXTCONF= yes
-
-WRKSRC= ${WRKDIR}/${PORTNAME}
-CONFIGURE_ARGS= --with-libperl=/usr/lib/libperl.so
-INSTALL_TARGET= site-install
-
-EXAMPLES= htmlparse.rb http.rb perllib.rb ping.rb \
- test.rb xmlparser.rb
-
-do-configure:
- @cd ${WRKSRC}/Ruby; \
- ${PERL} Makefile.PL
-
-post-build:
- @cd ${WRKSRC}/Ruby; \
- ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE}
-
-post-install:
- @cd ${WRKSRC}/Ruby; \
- ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} pure_install
-.if !defined(NOPORTEXAMPLES)
- ${MKDIR} ${RUBY_MODEXAMPLESDIR}
-.for f in ${EXAMPLES}
- ${INSTALL_DATA} ${WRKSRC}/samples/${f} ${RUBY_MODEXAMPLESDIR}/
-.endfor
-.endif
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${RUBY_MODDOCDIR}/ja/
- ${INSTALL_DATA} ${WRKSRC}/README.ja ${RUBY_MODDOCDIR}/ja/
-.endif
-
-.include <bsd.port.pre.mk>
-.if ${RUBY_VER} == 1.9
-BROKEN= does not build with ruby 1.9
-.endif
-.include <bsd.port.post.mk>
diff --git a/lang/ruby-perl/distinfo b/lang/ruby-perl/distinfo
deleted file mode 100644
index 69619a19d43d..000000000000
--- a/lang/ruby-perl/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (ruby/perl-0.2.9.tar.gz) = 67af313cf1e0f0135a0da52fece6f95afde25c47a14c512c0dcdcf926b019dd3
-SIZE (ruby/perl-0.2.9.tar.gz) = 14234
diff --git a/lang/ruby-perl/files/patch-perl.c b/lang/ruby-perl/files/patch-perl.c
deleted file mode 100644
index 8323016d971d..000000000000
--- a/lang/ruby-perl/files/patch-perl.c
+++ /dev/null
@@ -1,47 +0,0 @@
---- ./perl.c.orig 2009-06-18 03:30:23.290690879 -0400
-+++ ./perl.c 2009-06-18 03:30:13.000000000 -0400
-@@ -296,7 +296,7 @@
-
- ret = perl_eval_pv(RSTRING(pv)->ptr, Qfalse);
- if (SvTRUE(ERRSV)) {
-- rb_raise(ePerlError, SvPVx(ERRSV, PL_na));
-+ rb_raise(ePerlError, SvPVx_nolen(ERRSV));
- }
-
- return perl__Sv2Object(ret);
-@@ -352,7 +352,7 @@
- LEAVE;
-
- if (SvTRUE(ERRSV)) {
-- rb_raise(ePerlError, SvPVx(ERRSV, PL_na));
-+ rb_raise(ePerlError, SvPVx_nolen(ERRSV));
- }
-
- return ret;
-@@ -394,7 +394,7 @@
- LEAVE;
-
- if (SvTRUE(ERRSV)) {
-- rb_raise(ePerlError, SvPVx(ERRSV, PL_na));
-+ rb_raise(ePerlError, SvPVx_nolen(ERRSV));
- }
-
- return ret;
-@@ -453,7 +453,7 @@
- LEAVE;
-
- if (SvTRUE(ERRSV)) {
-- rb_raise(ePerlError, SvPVx(ERRSV, PL_na));
-+ rb_raise(ePerlError, SvPVx_nolen(ERRSV));
- }
-
- return ret;
-@@ -490,7 +490,7 @@
- LEAVE;
-
- if (SvTRUE(ERRSV)) {
-- rb_raise(ePerlError, SvPVx(ERRSV, PL_na));
-+ rb_raise(ePerlError, SvPVx_nolen(ERRSV));
- }
-
- return ret;
diff --git a/lang/ruby-perl/pkg-descr b/lang/ruby-perl/pkg-descr
deleted file mode 100644
index 2b76aa0f1f8b..000000000000
--- a/lang/ruby-perl/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-This is a Ruby extension module to use the functions of Perl from Ruby.
-
-You can also call Ruby functions back from within the Perl code.
-
-Author: Yoshida Masato <yoshidam@yoshidam.net>
-WWW: http://www.yoshidam.net/Ruby.html#perl
diff --git a/lang/ruby-perl/pkg-plist b/lang/ruby-perl/pkg-plist
deleted file mode 100644
index d569531b22df..000000000000
--- a/lang/ruby-perl/pkg-plist
+++ /dev/null
@@ -1,16 +0,0 @@
-%%RUBY_SITEARCHLIBDIR%%/perl.so
-%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/htmlparse.rb
-%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/http.rb
-%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/perllib.rb
-%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/ping.rb
-%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/test.rb
-%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/xmlparser.rb
-%%PORTEXAMPLES%%@dirrm %%RUBY_MODEXAMPLESDIR%%
-%%PORTEXAMPLES%%%%RUBY_MODDOCDIR%%/ja/README.ja
-%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%/ja
-%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%
-%%SITE_PERL%%/%%PERL_ARCH%%/Ruby.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Ruby/.packlist
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Ruby/Ruby.bs
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Ruby/Ruby.so
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Ruby