aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/cython/Makefile2
-rw-r--r--lang/cython3/Makefile5
3 files changed, 7 insertions, 1 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 051821d63344..1b7abd717085 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -50,6 +50,7 @@
SUBDIR += cparser
SUBDIR += csharp-mode.el
SUBDIR += cython
+ SUBDIR += cython3
SUBDIR += diveintopython
SUBDIR += dlv
SUBDIR += dmd1
diff --git a/lang/cython/Makefile b/lang/cython/Makefile
index 853d9914e546..0ee5f675d2f3 100644
--- a/lang/cython/Makefile
+++ b/lang/cython/Makefile
@@ -14,7 +14,7 @@ COMMENT= Compiler for Writing C Extensions for the Python Language
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-USES= python
+USES?= python
USE_PYTHON= autoplist distutils
post-install:
diff --git a/lang/cython3/Makefile b/lang/cython3/Makefile
new file mode 100644
index 000000000000..aade1d2c2236
--- /dev/null
+++ b/lang/cython3/Makefile
@@ -0,0 +1,5 @@
+MASTERDIR= ${.CURDIR}/../cython
+
+USES= python:3.3+
+
+.include "${MASTERDIR}/Makefile"