aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
Diffstat (limited to 'lang')
-rw-r--r--lang/erlang/Makefile2
-rw-r--r--lang/erlang/files/patch-erts_emulator_sys_unix_sys__float.c13
-rw-r--r--lang/erlang14/Makefile2
-rw-r--r--lang/erlang14/files/patch-erts_emulator_sys_unix_sys__float.c13
4 files changed, 28 insertions, 2 deletions
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index 0f0287f76df8..76b230947a6e 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -7,7 +7,7 @@
PORTNAME= erlang
PORTVERSION= r13b01
-PORTREVISION= 4
+PORTREVISION= 5
PORTEPOCH= 1
CATEGORIES= lang parallel java
MASTER_SITES= http://www.erlang.org/download/ \
diff --git a/lang/erlang/files/patch-erts_emulator_sys_unix_sys__float.c b/lang/erlang/files/patch-erts_emulator_sys_unix_sys__float.c
new file mode 100644
index 000000000000..a21b4d08e33d
--- /dev/null
+++ b/lang/erlang/files/patch-erts_emulator_sys_unix_sys__float.c
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- erts/emulator/sys/unix/sys_float.c.orig
++++ erts/emulator/sys/unix/sys_float.c
+@@ -57,6 +57,7 @@
+ void erts_thread_init_fp_exception(void)
+ {
+ unsigned long *fpe = erts_alloc(ERTS_ALC_T_FP_EXCEPTION, sizeof(*fpe));
++ *fpe = 0;
+ erts_tsd_set(fpe_key, fpe);
+ }
+
diff --git a/lang/erlang14/Makefile b/lang/erlang14/Makefile
index 0f0287f76df8..76b230947a6e 100644
--- a/lang/erlang14/Makefile
+++ b/lang/erlang14/Makefile
@@ -7,7 +7,7 @@
PORTNAME= erlang
PORTVERSION= r13b01
-PORTREVISION= 4
+PORTREVISION= 5
PORTEPOCH= 1
CATEGORIES= lang parallel java
MASTER_SITES= http://www.erlang.org/download/ \
diff --git a/lang/erlang14/files/patch-erts_emulator_sys_unix_sys__float.c b/lang/erlang14/files/patch-erts_emulator_sys_unix_sys__float.c
new file mode 100644
index 000000000000..a21b4d08e33d
--- /dev/null
+++ b/lang/erlang14/files/patch-erts_emulator_sys_unix_sys__float.c
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- erts/emulator/sys/unix/sys_float.c.orig
++++ erts/emulator/sys/unix/sys_float.c
+@@ -57,6 +57,7 @@
+ void erts_thread_init_fp_exception(void)
+ {
+ unsigned long *fpe = erts_alloc(ERTS_ALC_T_FP_EXCEPTION, sizeof(*fpe));
++ *fpe = 0;
+ erts_tsd_set(fpe_key, fpe);
+ }
+