aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
Diffstat (limited to 'lang')
-rw-r--r--lang/erlang/Makefile9
-rw-r--r--lang/erlang14/Makefile9
2 files changed, 18 insertions, 0 deletions
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index f12bac975db5..7e02b13f8c66 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -196,6 +196,15 @@ post-install:
@${ECHO_CMD} "x!" >> ${WRKDIR}/ex.script
@cd ${WRKDIR} ; ex < ex.script
+buildplt:
+ @${ECHO_CMD} =====================================================
+ @${ECHO_CMD} WARNING: building a full PLT may literally take hours
+ @${ECHO_CMD}
+ @${ECHO_CMD} You may wish to settle for the standard PLT built by
+ @${ECHO_CMD} dialyzer on the first run.
+ @${ECHO_CMD} =====================================================
+ @cd ${PREFIX}/lib/erlang/lib ; ${PREFIX}/bin/dialyzer --verbose --build_plt --output_plt ${HOME}/.dialyzer_plt -c $$(find ${OTP_LIBS} -name ebin -maxdepth 1) || true
+
.include "Makefile.lib"
.include "Makefile.man"
diff --git a/lang/erlang14/Makefile b/lang/erlang14/Makefile
index f12bac975db5..7e02b13f8c66 100644
--- a/lang/erlang14/Makefile
+++ b/lang/erlang14/Makefile
@@ -196,6 +196,15 @@ post-install:
@${ECHO_CMD} "x!" >> ${WRKDIR}/ex.script
@cd ${WRKDIR} ; ex < ex.script
+buildplt:
+ @${ECHO_CMD} =====================================================
+ @${ECHO_CMD} WARNING: building a full PLT may literally take hours
+ @${ECHO_CMD}
+ @${ECHO_CMD} You may wish to settle for the standard PLT built by
+ @${ECHO_CMD} dialyzer on the first run.
+ @${ECHO_CMD} =====================================================
+ @cd ${PREFIX}/lib/erlang/lib ; ${PREFIX}/bin/dialyzer --verbose --build_plt --output_plt ${HOME}/.dialyzer_plt -c $$(find ${OTP_LIBS} -name ebin -maxdepth 1) || true
+
.include "Makefile.lib"
.include "Makefile.man"