aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc32/Makefile26
-rw-r--r--lang/gcc32/distinfo1
-rw-r--r--lang/gcc32/files/opt.patch-bc11
3 files changed, 37 insertions, 1 deletions
diff --git a/lang/gcc32/Makefile b/lang/gcc32/Makefile
index 09fc818fc55e..45ac81da03f6 100644
--- a/lang/gcc32/Makefile
+++ b/lang/gcc32/Makefile
@@ -13,7 +13,8 @@ PORTNAME= gcc
PORTVERSION= 3.2.2
PORTREVISION= ${SNAPVER}
CATEGORIES= lang java
-MASTER_SITES= ${MASTER_SITE_GCC}
+MASTER_SITES= ${MASTER_SITE_GCC} \
+ http://web.inter.NL.net/hcc/Haj.Ten.Brugge/:bc
MASTER_SITE_SUBDIR= releases/gcc-${PORTVERSION}
DISTFILES= gcc-core-${PORTVERSION}${EXTRACT_SUFX} \
gcc-testsuite-${PORTVERSION}${EXTRACT_SUFX} \
@@ -28,6 +29,14 @@ DISTFILES= gcc-core-${PORTVERSION}${EXTRACT_SUFX} \
MAINTAINER= gerald@FreeBSD.org
COMMENT= GNU Compiler Collection 3.2.2
+.if defined (WITH_BOUNDSCHECKING)
+# Fetch another file, but don't extract it. Also add another patchfile.
+BCPATCH= bounds-checking-gcc-3.2.2-1.00.patch.bz2
+DISTFILES+= ${BCPATCH}:bc
+EXTRACT_ONLY= ${DISTFILES:S/${BCPATCH}:bc//}
+EXTRA_PATCHES= ${FILESDIR}/opt.patch-bc
+.endif
+
LATEST_LINK= gcc32
USE_BZIP2= yes
@@ -78,6 +87,11 @@ MAN7= fsf-funding.7 gfdl.7 gpl.7
pre-fetch:
@${ECHO} "Making GCC ${DISTNAME:S/^gcc-//} for ${OPSYS} ${OSREL} ${PORTOBJFORMAT} target ${CONFIGURE_TARGET}"
+.if !defined(WITH_BOUNDSCHECKING)
+ @${ECHO_MSG} "You can enable fine-grained bounds-checking support for compiled C programs"
+ @${ECHO_MSG} "by defining WITH_BOUNDSCHECKING. Compile and link with \"-fbounds-checking\""
+ @${ECHO_MSG} "to use."
+.endif
.if defined(CVS_DATE)
DIST_SUBDIR= ${PKGNAME}
@@ -110,6 +124,16 @@ do-extract:
cd ${DISTDIR}/${DIST_SUBDIR}/gcc ; pax -pe -rwt . ${SRCDIR}
.endif # CVS_DATE
+.if defined(WITH_BOUNDSCHECKING)
+# Extract bounds-checking patch, removing the ada parts of the patch with sed.
+pre-patch:
+ ( cd ${_DISTDIR} && \
+ ${BZCAT} ${BCPATCH} | \
+ ${SED} -e '/^--- .*ada/,/^diff/d' | \
+ ${PATCH} -d ${PATCH_WRKSRC} -E -p1 --quiet \
+ )
+.endif
+
pre-configure:
@# Keep from running `autoconf' and `autoheader' since we modified
@# configure.in by patching it.
diff --git a/lang/gcc32/distinfo b/lang/gcc32/distinfo
index ae024722a95f..da7147d1e97a 100644
--- a/lang/gcc32/distinfo
+++ b/lang/gcc32/distinfo
@@ -4,3 +4,4 @@ MD5 (gcc-g++-3.2.2.tar.bz2) = 86b63f1375ce75c5df03cbf23731c3c1
MD5 (gcc-g77-3.2.2.tar.bz2) = 0b220a0cd5dd471c34c080952265e91e
MD5 (gcc-java-3.2.2.tar.bz2) = 05660a2dc4c874bbb361dec8363da852
MD5 (gcc-objc-3.2.2.tar.bz2) = c2c99dca89281512403b9805c59ffd2d
+MD5 (bounds-checking-gcc-3.2.2-1.00.patch.bz2) = 44a7e5030fde6e0e9350aa5029eacbaf
diff --git a/lang/gcc32/files/opt.patch-bc b/lang/gcc32/files/opt.patch-bc
new file mode 100644
index 000000000000..8b310da4e992
--- /dev/null
+++ b/lang/gcc32/files/opt.patch-bc
@@ -0,0 +1,11 @@
+--- gcc/bounds/lib/malloc/Makefile.orig Fri Sep 28 15:31:19 2001
++++ gcc/bounds/lib/malloc/Makefile Mon Oct 1 13:58:20 2001
+@@ -52,7 +52,7 @@ VPATH = $(srcdir)/bounds/lib/malloc
+ SUBDIR_INCLUDES = -I$(srcdir)/bounds/lib/malloc -I../../.. -I$(srcdir) -I$(srcdir)/config -I../../../../include
+
+ # Use this on System V.
+-CPPFLAGS = -DUSG
++CPPFLAGS = -DBSD4_2
+
+ .c.o:
+ $(GCC_FOR_TARGET) -Wall $(OPTIMIZE) $(CPPFLAGS) \
ss='commitgraph'>| | | | | | | multimedia/phonon port has been split into phonon itself, phonon-xine and phono-gstreamer backends. After updating phonon port you have to install at least one backend. phonon-xine backend is recommended for KDE. * The KDE FreeBSD team is proud to announce the release of KDE 4.2.0miwi2009-02-092-24/+11 | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | for FreeBSD. The official KDE 4.2.0 (Codename: "The Answer") release notes can be found at: http://kde.org/announcements/4.2/index.php. New supported languages include Arabic, Icelandic, Basque, Hebrew, Romanian, Tajik and several Indian languages (Bengali India, Gujarati, Kannada, Maithili, Marathi) indicating a rise in popularity in this part of Asia. New ports for KDE 4.2.0: arabic/kde4-l10n Arabic hebrew/kde4-l10n Hebrew misc/kde4-l10n-bn_IN Bengali (India) misc/kde4-l10n-eu Basque misc/kde4-l10n-gu Gujarati misc/kde4-l10n-is Icelandic misc/kde4-l10n-kn Kannada misc/kde4-l10n-mai Maithili misc/kde4-l10n-mr Marathi misc/kde4-l10n-ro Romanian misc/kde4-l10n-tg Tajik math/eigen2 Lightweight library for vector and matrix math graphics/kipi-plugins-kde4 KDE4 kipi graphics plugins sysutils/policykit-kde PolicyKit manager for KDE Unfortunately FreeBSD 6.4 support is dropped. We'd like to say thanks for feedback and help to: Matt Tosto, Kris Moore, stickibit, David Johnson, Markus Brueffer, David Naylor, Thomas Schlesinger, Warren Liddell, Thomas Abthorpe, Diego Depaoli, Mats Andreassen, portmgr for exp-run and repocopies. * - Update to 1.2.8gabor2009-02-086-16/+58 | | | | | | | - Fix installed Hungarian dictionary locating error PR: ports/131366 Submitted by: Janos Mohacsi <janos.mohacsi@bsd.hu> (maintainer) * - Update to 1.4gabor2009-02-082-4/+4 | | | | | PR: ports/131363 Submitted by: Janos Mohacsi <janos.mohacsi@bsd.hu> (maintainer) * kde@freebsd team is pleased to announce KDE 4.1.4, the last bugfix release ↵makc2009-01-143-6/+9 | | | | | | | | | | | | | | in 4.1.x series. You have only two weeks to play with it -- KDE 4.2.0 is coming ;) Great thanks for those who helped us with testing 4.1.2 and 4.1.3 during long-long ports ice-age. For lists of bugfixes and improvements please see: http://www.kde.org/announcements/changelogs/changelog4_1_1to4_1_2.php http://www.kde.org/announcements/changelogs/changelog4_1_2to4_1_3.php http://www.kde.org/announcements/changelogs/changelog4_1_3to4_1_4.php Approved by: miwi (mentor) * Turns out, libdata/pkgconfig/ is already part of mtree and needs neithermi2008-09-092-3/+1 | | | | | | | being created on install nor removed at deinstall. Notified by: QATindy Approved by: portmgr (pav) * Fix the incorrect location hunspell.pc. No PORTREVISION bump, becausemi2008-09-091-1/+1 | | | | | | | no package could've been created with the current plist. Notified by: QATindy Approved by: portmgr (pav) * Correct the destination of hunspell.pc file -- according to pav,mi2008-09-082-3/+3 | | | | it ought to go to libdata/pkgconfig/ rather than lib/pkgconfig. * Add two directories missing from plist...mi2008-09-041-0/+2 | | | | Notified by: QA-Tindy * Upgrade from 1.2.2b to 1.2.7.mi2008-09-046-47/+73 | | | | | | | | | | | | | | Install header-files, which make the port's shared library usable by other applications -- such as, most importantly, OpenOffice. While here, ensure, the already installed -lintl is used, and configure in the use of readline too. Rephrase COMMENT to ease the confusion, that the port is only of interest to Hungarian-speakers. It is not -- the software is an improved version of myspell and can work with any dictionary. Approved by: maintainer * The KDE FreeBSD team is proud to announce the release of KDE 4.1.1miwi2008-09-032-5/+21 | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | for FreeBSD. The official KDE 4.1.1 release notes can be found at http://www.kde.org/announcements/changelogs/changelog4_1to4_1_1.php. KDE Community ships sirst translation and service release of the 4.1 dree desktop, containing numerous bugfixes, Performance Improvements and Translation Updates. Pretty much all applications have received the developers' attention, resulting in a long list of bugfixes and improvements. The most significant changes are: * Significant performance, interaction and rendering correctness improvements in KHTML and Konqueror, KDE's web browser * User interaction, rendering and stability fixes in Plasma, the KDE4 desktop shell * PDF backend fixes in the document viewer Okular * Fixes in Gwenview, the image viewer's thumbnailing, more robust retrieval and display of images with broken metadata * Stability and interaction fixes in KMail New Ports: - graphics/kcoloredit * KColorEdit is a palette files editor. It can be used for editing color palettes and for color choosing and naming. - graphics/kgraphviewer * KGraphViewer is a GraphViz DOT graph viewer for KDE. The GraphViz programs are free-software layout engines for graphs. KGraphViewer displays the graphs in a modern, user-friendly GUI with all the power of a well integrated KDE application. - graphics/kiconedit * KIconEdit is designed to help create icons for KDE using the standard icon palette. - graphics/skanlite * Skanlite is a simple image scanning application that does nothing more than scan and save images. Skanlite can open a save dialog for every image scanned or save the images immediately in a specified directory with auto-generated names and format. The user can also choose to show the scanned image before saving. * The KDE FreeBSD team is proud to announce the releasemiwi2008-08-291-3/+3 | | | | | | | | | | | | | | | | | | | of KDE 3.5.10 for FreeBSD. The official KDE 3.5.10 release notes can be found at: http://www.kde.org/announcements/announce-3.5.10.php While not a very exciting release in terms of features, 3.5.10 brings a couple of nice bugfixes and translation updates to those who choose to stay with KDE 3.5. The fixes are thinly spread across KPDF with a number of crash fixes, KGPG and probably most interesting various fixes in kicker, KDE3's panel: * Improved visibility on transparent backgrounds * Themed arrow buttons in applets that were missing them * Layout and antialiasing fixes in various applets Approved by: portmgr (erwin/pav) * The KDE FreeBSD team is proud to announce the releasemiwi2008-08-182-10/+64 | | | | | | | | | | | | | | | | of KDE 3.5.9 for FreeBSD. The official KDE 3.5.9 release notes can be found at: http://www.kde.org/announcements/announce-3.5.9.php After the KDE 4.1.0 import the team found time to make KDE 3.5.9 ready for the Ports tree. KDE 3.5.9 was released six months ago and 3.5.10 is coming soon. We are not sure we have time to get 3.5.10 for FreeBSD 7.1/6.4 release, but we would have minimum 3.5.9 for those people who prefer to stay with KDE3. Of course Thanks to all Testers. * The KDE FreeBSD team is proud to announce the release of KDE 4.1.0miwi2008-08-105-484/+244 | | | | | | | | | | | | | | | | | | | | | for FreeBSD. The official KDE 4.1.0 release notes can be found at http://www.kde.org/announcements/4.1/. Some note: * Prefix KDE4 will be install into a custom prefixes namely ${LOCALBASE}/kde4. KDE4 and KDE3 can co-exist * Sound For sound to work, it is necessary to have dbus and hal enabled in your system. Please see the respective documentation on how to enable these. For more Informations see the HEADS UP at ports@ and kde-freebsd@ or our wiki page http://wiki.freebsd.org/KDE4/Install. Have fun! * PHP Documentation in these language has been removed from the distribution.edwin2008-08-042-14/+0 |