aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/phc/Makefile23
-rw-r--r--lang/phc/distinfo3
-rw-r--r--lang/phc/pkg-descr10
4 files changed, 37 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index b70e671eba70..4b373a2a2a09 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -196,6 +196,7 @@
SUBDIR += perl5.8
SUBDIR += pexts
SUBDIR += pfe-devel
+ SUBDIR += phc
SUBDIR += php-mode.el
SUBDIR += php4
SUBDIR += php4-extensions
diff --git a/lang/phc/Makefile b/lang/phc/Makefile
new file mode 100644
index 000000000000..d9cd1081bf3c
--- /dev/null
+++ b/lang/phc/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: phc
+# Date created: July 4th, 2006
+# Whom: Conor McDermottroe <ports@mcdermottroe.com>
+# ex:ts=8
+#
+# $FreeBSD$
+#
+
+PORTNAME= phc
+DISTVERSION= 0.1.6rc1
+CATEGORIES= lang
+MASTER_SITES= http://www.phpcompiler.org/src/archive/
+
+MAINTAINER= ports@mcdermottroe.com
+COMMENT= A compiler for the PHP language
+
+USE_GCC= 3.4+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+PLIST_FILES= bin/phc
+
+.include <bsd.port.mk>
diff --git a/lang/phc/distinfo b/lang/phc/distinfo
new file mode 100644
index 000000000000..894bdc50e081
--- /dev/null
+++ b/lang/phc/distinfo
@@ -0,0 +1,3 @@
+MD5 (phc-0.1.6rc1.tar.gz) = 79f53d24b56a981963dc6ed1e67a9ce0
+SHA256 (phc-0.1.6rc1.tar.gz) = a4516336179fa2bcc29b9ae7e3c8fc62ab03a2064a633a6290141d6d19c2699a
+SIZE (phc-0.1.6rc1.tar.gz) = 271874
diff --git a/lang/phc/pkg-descr b/lang/phc/pkg-descr
new file mode 100644
index 000000000000..d850e0efe5e7
--- /dev/null
+++ b/lang/phc/pkg-descr
@@ -0,0 +1,10 @@
+phc is a framework for static analysis of PHP scripts, PHP source to source
+transformations, and ultimately compiling PHP scripts down to native machine
+code.
+
+The current release does not yet compile PHP and is therefore not yet useful
+for end-users. It is however useful for writing tools that operate on PHP
+scripts, such as refactoring tools, aspect weavers, or obfuscators. See the
+website to get an idea of what is planned for coming releases of phc.
+
+WWW: http://www.phpcompiler.org/