aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
Diffstat (limited to 'lang')
-rw-r--r--lang/erlang/Makefile94
-rw-r--r--lang/erlang/Makefile.lib114
-rw-r--r--lang/erlang/Makefile.man16
-rw-r--r--lang/erlang/distinfo12
-rw-r--r--lang/erlang/files/patch-erts_emulator_drivers_common_inet__drv.c26
-rw-r--r--lang/erlang/pkg-plist1
6 files changed, 98 insertions, 165 deletions
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index be93982abff5..12ba2a372437 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= erlang
-PORTVERSION= r14b04
-PORTREVISION= 3
-PORTEPOCH= 1
+DISTVERSION= R15B01
+PORTVERSION= 15.b.01
+PORTEPOCH= 2
CATEGORIES= lang parallel java
MASTER_SITES= http://www.erlang.org/download/:erlangorg \
http://erlang.stacken.kth.se/download/:erlangorg \
@@ -17,7 +17,7 @@ MASTER_SITES= http://www.erlang.org/download/:erlangorg \
http://www.erlang.se/publications/:publications \
http://www.sics.se/~joe/thesis/:joe \
${MASTER_SITE_LOCAL:S/$/:local/:S,%SUBDIR%/,olgeni/,}
-DISTNAME= otp_src_R14B04
+DISTNAME= otp_src_${DISTVERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:erlangorg \
${ERLANG_MAN}:erlangorg \
${ERLANG_DOCS}:erlangorg \
@@ -42,46 +42,32 @@ SUB_LIST= TOOLS_VSN=${TOOLS_VSN}
MAKE_JOBS_UNSAFE=yes
-OPTIONS_DEFINE= HIPE JAVA KQUEUE ODBC OPENSSL SCTP SMP THREADS WX X11
+OPTIONS_DEFINE= DOCS GS HIPE JAVA KQUEUE ODBC OPENSSL SCTP SMP THREADS WX
OPTIONS_SINGLE= ODBC
OPTIONS_SINGLE_ODBC= IODBC UNIXODBC
HIPE_DESC= Build native HiPE compiler
KQUEUE_DESC= Enable Kernel Poll (kqueue) support
-UNIXODBC_DESC= Build with unixODBC support
-IODBC_DESC= Build with libiodbc support
SCTP_DESC= Enable SCTP support
SMP_DESC= Enable SMP support
-WX_DESC= Enable WX extensions
+WX_DESC= Enable WX application
+GS_DESC= Enable GS application (deprecated)
-OPTIONS_DEFAULT= SMP OPENSSL THREADS SCTP KQUEUE
+OPTIONS_DEFAULT=SMP OPENSSL THREADS SCTP KQUEUE
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MOPENSSL}
-USE_OPENSSL=YES
-CONFIGURE_ARGS+=--enable-ssl=${OPENSSLBASE} --enable-dynamic-ssl-lib
+USE_OPENSSL= yes
+CONFIGURE_ARGS+=--with-ssl=${OPENSSLBASE}
.else
-CONFIGURE_ARGS+=--disable-ssl
+CONFIGURE_ARGS+=--without-ssl
.endif
-.include <bsd.port.pre.mk>
-
-# The Java applications that are part of the Erlang distribution are
-# not strictly necessary - it is included for completeness sake. A
-# problem with the Erlang build procedure is that it only checks if
-# javac is in the regular path - and then assumes that all of the jdk
-# utilities is in the path as well. The only way to make sure that
-# this is the case (that I could think of at least) was to make sure
-# ${JAVA_HOME}/bin is added to the PATH, using the *_ENV macros.
-
.if ${PORT_OPTIONS:MJAVA}
USE_JAVA= yes
-JAVA_VERSION= 1.5+
-# Make sure ${JAVA_HOME}/bin is in the path
-CONFIGURE_ENV+= PATH=${PATH}:${JAVA_HOME}/bin
-MAKE_ENV+= PATH=${PATH}:${JAVA_HOME}/bin
-SCRIPT_ENV+= PATH=${PATH}:${JAVA_HOME}/bin
+CONFIGURE_ARGS+=--with-javac
+CONFIGURE_ENV+= ac_cv_prog_JAVAC="${JAVAC}"
.else
CONFIGURE_ARGS+=--without-javac
.endif
@@ -98,15 +84,16 @@ CONFIGURE_ARGS+=--enable-kernel-poll
CONFIGURE_ARGS+=--disable-kernel-poll
.endif
-.if ${PORT_OPTIONS:MX11}
+.if ${PORT_OPTIONS:MGS}
USE_TK_RUN= yes
+.endif
+
.if ${PORT_OPTIONS:MWX}
USE_WX= 2.8+
WX_COMPS= wx contrib
WX_UNICODE= yes
CONFIGURE_ARGS+=--with-wx-config=${WX_CONFIG}
.endif
-.endif
USE_GMAKE= yes
USE_CSTD= gnu89
@@ -114,27 +101,20 @@ USE_PERL5= yes
USE_RC_SUBR= epmd
GNU_CONFIGURE= yes
ONLY_FOR_ARCHS= i386 amd64 sparc64 powerpc
-REINPLACE_ARGS= -i
-
-.if (${OSVERSION} < 700000)
-USE_GCC= 4.2+
-.endif
.if ${PORT_OPTIONS:MODBC}
CONFIGURE_ARGS+=--with-odbc
.if ${PORT_OPTIONS:MUNIXODBC}
-LIB_DEPENDS+= odbc.2:${PORTSDIR}/databases/unixODBC
+LIB_DEPENDS+= odbc:${PORTSDIR}/databases/unixODBC
.elif ${PORT_OPTIONS:MIODBC}
-LIB_DEPENDS+= iodbc.3:${PORTSDIR}/databases/libiodbc
+LIB_DEPENDS+= iodbc:${PORTSDIR}/databases/libiodbc
.endif
.else
CONFIGURE_ARGS+=--without-odbc
.endif
-ERLANG_MAN= otp_doc_man_R14B04.tar.gz
-.if !defined(NOPORTDOCS)
-ERLANG_DOCS= otp_doc_html_R14B04.tar.gz
-.endif
+ERLANG_MAN= otp_doc_man_${DISTVERSION}.tar.gz
+ERLANG_DOCS= otp_doc_html_${DISTVERSION}.tar.gz
ERLANG_PLIST= ${WRKDIR}/pkg-plist
.if ${PORT_OPTIONS:MTHREADS}
@@ -144,13 +124,14 @@ CONFIGURE_ARGS+=--disable-threads
.endif
.if ${PORT_OPTIONS:MSCTP}
-CONFIGURE_ARGS+=--with-sctp
+CONFIGURE_ARGS+=--enable-sctp
.else
-CONFIGURE_ARGS+=--without-sctp
+CONFIGURE_ARGS+=--disable-sctp
.endif
# enabling --enable-smp-support crashes the OS when
# net_kernel:start([node_name, shortnames]) invoked repeatedly
+# TODO verify if it still applies
.if ${PORT_OPTIONS:MSMP}
CONFIGURE_ARGS+=--enable-smp-support
@@ -158,10 +139,6 @@ CONFIGURE_ARGS+=--enable-smp-support
CONFIGURE_ARGS+=--disable-smp-support
.endif
-CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-PLIST_SUB+= TOOLS_VSN=${TOOLS_VSN}
-
.if ${ARCH} == i386
MAKE_ARGS+= ARCH=x86
.endif
@@ -178,27 +155,6 @@ MAN3PREFIX= ${PREFIX}/lib/erlang
MAN4PREFIX= ${PREFIX}/lib/erlang
MAN6PREFIX= ${PREFIX}/lib/erlang
-pre-configure:
- @${REINPLACE_CMD} -e 's#%%CFLAGS%%#${CFLAGS}#g' ${WRKSRC}/lib/wx/configure
-
-# Check if ${JAVAC} exists.
-.if ${PORT_OPTIONS:MJAVA}
- @if [ ! -x ${JAVAC} ]; then \
- ${ECHO_MSG} ">> Error: cannot find ${JAVAC}."; \
- exit 1; \
- fi
-.endif
-
-# If X11 is not used, skip the gs application.
-.if defined(WITHOUT_X11)
- @${ECHO_CMD} "WITHOUT_X11 defined" > ${WRKSRC}/lib/gs/SKIP
-.endif
-
-# If ODBC is not used, skip the odbc application.
-.if defined(WITHOUT_ODBC)
- @${ECHO_CMD} "WITHOUT_ODBC defined" > ${WRKSRC}/lib/odbc/SKIP
-.endif
-
# Install documentation. (HTML docs need to be in same dir as the
# rest, not in share/doc/erlang as it should, because of relative
# links in the documentation.
@@ -210,7 +166,7 @@ post-install:
"man/man$${SECTION}/*.$${SECTION}" || ${TRUE}; \
done
@${RM} -rf ${PREFIX}/lib/erlang/man/cat?
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${TAR} --unlink -xzpf ${DISTDIR}/${DIST_SUBDIR}/${ERLANG_DOCS} \
-C ${PREFIX}/lib/erlang
@${INSTALL_DATA} ${WRKSRC}/lib/dialyzer/doc/*.txt \
@@ -287,4 +243,4 @@ buildplt:
.include "Makefile.lib"
.include "Makefile.man"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/erlang/Makefile.lib b/lang/erlang/Makefile.lib
index 87e3ec454187..d81b6168f3d2 100644
--- a/lang/erlang/Makefile.lib
+++ b/lang/erlang/Makefile.lib
@@ -1,59 +1,59 @@
# $FreeBSD$
-TOOLS_VSN= 2.6.6.5
-OTP_LIBS= appmon-2.1.13 \
- asn1-1.6.18 \
- common_test-1.5.5 \
- compiler-4.7.5 \
- cosEvent-2.1.11 \
- cosEventDomain-1.1.11 \
- cosFileTransfer-1.1.12 \
- cosNotification-1.1.17 \
- cosProperty-1.1.14 \
- cosTime-1.1.11 \
- cosTransactions-1.2.11 \
- crypto-2.0.4 \
- debugger-3.2.6 \
- dialyzer-2.4.4 \
- diameter-0.10 \
- docbuilder-0.9.8.11 \
- edoc-0.7.9 \
- erl_docgen-0.2.6 \
- erl_interface-3.7.5 \
- erts-5.8.5 \
- et-1.4.4 \
- eunit-2.2.1 \
- gs-1.5.14 \
- hipe-3.8.1 \
- ic-4.2.27 \
- inets-5.7.1 \
- inviso-0.6.2 \
- jinterface-1.5.4 \
- kernel-2.14.5 \
- megaco-3.15.1.1 \
- mnesia-4.5 \
- observer-0.9.10 \
- odbc-2.10.11 \
- orber-3.6.22 \
- os_mon-2.2.7 \
- otp_mibs-1.0.6 \
- parsetools-2.0.6 \
- percept-0.8.6 \
- pman-2.7.1 \
- public_key-0.13 \
- reltool-0.5.7 \
- runtime_tools-1.8.6 \
- sasl-2.1.10 \
- snmp-4.21.1 \
- ssh-2.0.8 \
- ssl-4.1.6 \
- stdlib-1.17.5 \
- syntax_tools-1.6.7.1 \
- test_server-3.4.5 \
- toolbar-1.4.2 \
- tools-2.6.6.5 \
- tv-2.1.4.7 \
- typer-0.9.2 \
- webtool-0.8.9 \
- wx-0.99 \
- xmerl-1.2.10
+TOOLS_VSN= 2.6.7
+OTP_LIBS= appmon-2.1.14.1 \
+ asn1-1.7 \
+ common_test-1.6.1 \
+ compiler-4.8.1 \
+ cosEvent-2.1.12 \
+ cosEventDomain-1.1.12 \
+ cosFileTransfer-1.1.13 \
+ cosNotification-1.1.18 \
+ cosProperty-1.1.15 \
+ cosTime-1.1.12 \
+ cosTransactions-1.2.12 \
+ crypto-2.1 \
+ debugger-3.2.8 \
+ dialyzer-2.5.1 \
+ diameter-1.1 \
+ edoc-0.7.9.1 \
+ eldap-1.0 \
+ erl_docgen-0.3.1 \
+ erl_interface-3.7.7 \
+ erts-5.9.1 \
+ et-1.4.4.1 \
+ eunit-2.2.2 \
+ gs-1.5.15.1 \
+ hipe-3.9.1 \
+ ic-4.2.30 \
+ inets-5.9 \
+ inviso-0.6.3 \
+ jinterface-1.5.6 \
+ kernel-2.15.1 \
+ megaco-3.16.0.1 \
+ mnesia-4.7 \
+ observer-1.1 \
+ odbc-2.10.12 \
+ orber-3.6.24 \
+ os_mon-2.2.9 \
+ otp_mibs-1.0.7 \
+ parsetools-2.0.7 \
+ percept-0.8.6.1 \
+ pman-2.7.1.2 \
+ public_key-0.15 \
+ reltool-0.6 \
+ runtime_tools-1.8.8 \
+ sasl-2.2.1 \
+ snmp-4.22 \
+ ssh-2.1 \
+ ssl-5.0.1 \
+ stdlib-1.18.1 \
+ syntax_tools-1.6.8 \
+ test_server-3.5.1 \
+ toolbar-1.4.2.2 \
+ tools-2.6.7 \
+ tv-2.1.4.9 \
+ typer-0.9.3 \
+ webtool-0.8.9.1 \
+ wx-0.99.2 \
+ xmerl-1.3.1
diff --git a/lang/erlang/Makefile.man b/lang/erlang/Makefile.man
index 3cc1e56e6630..ee91ddcf550e 100644
--- a/lang/erlang/Makefile.man
+++ b/lang/erlang/Makefile.man
@@ -134,10 +134,8 @@ MAN3= CosEventChannelAdmin.3 \
digraph_utils.3 \
disk_log.3 \
disksup.3 \
- docb_gen.3 \
- docb_transform.3 \
- docb_xml_check.3 \
driver_entry.3 \
+ dyntrace.3 \
edoc.3 \
edoc_doclet.3 \
edoc_extract.3 \
@@ -147,6 +145,7 @@ MAN3= CosEventChannelAdmin.3 \
egd.3 \
ei.3 \
ei_connect.3 \
+ eldap.3 \
epp.3 \
epp_dodger.3 \
eprof.3 \
@@ -215,6 +214,7 @@ MAN3= CosEventChannelAdmin.3 \
glu.3 \
gs.3 \
heart.3 \
+ http_uri.3 \
httpc.3 \
httpd.3 \
httpd_conf.3 \
@@ -274,8 +274,8 @@ MAN3= CosEventChannelAdmin.3 \
net_adm.3 \
net_kernel.3 \
nteventlog.3 \
+ observer.3 \
odbc.3 \
- old_ssl.3 \
orber.3 \
orber_acl.3 \
orber_diagnostics.3 \
@@ -304,7 +304,6 @@ MAN3= CosEventChannelAdmin.3 \
random.3 \
rb.3 \
re.3 \
- regexp.3 \
registry.3 \
release_handler.3 \
reltool.3 \
@@ -567,7 +566,10 @@ MAN3= CosEventChannelAdmin.3 \
wxStyledTextCtrl.3 \
wxStyledTextEvent.3 \
wxSysColourChangedEvent.3 \
+ wxSystemOptions.3 \
wxSystemSettings.3 \
+ wxTaskBarIcon.3 \
+ wxTaskBarIconEvent.3 \
wxTextAttr.3 \
wxTextCtrl.3 \
wxTextDataObject.3 \
@@ -601,7 +603,7 @@ MAN3= CosEventChannelAdmin.3 \
zlib.3 \
zlib_stub.3
-MAN4= app.4 \
+MAN4= app.4 \
appup.4 \
config.4 \
diameter_dict.4 \
@@ -611,7 +613,7 @@ MAN4= app.4 \
MAN6= common_test.6 \
crypto.6 \
- docbuilder.6 \
+ erl_docgen.6 \
kernel.6 \
observer.6 \
os_mon.6 \
diff --git a/lang/erlang/distinfo b/lang/erlang/distinfo
index fc115c9a2940..f7d9b85ef0ff 100644
--- a/lang/erlang/distinfo
+++ b/lang/erlang/distinfo
@@ -1,9 +1,9 @@
-SHA256 (erlang/otp_src_R14B04.tar.gz) = 099b35910e635b9148ac90f70fd9dd592920ed02406eb26c349efd8d1e959b6e
-SIZE (erlang/otp_src_R14B04.tar.gz) = 70773703
-SHA256 (erlang/otp_doc_man_R14B04.tar.gz) = 8514511e8a8ac3f3f67db06f333548edf283d9a8afcbc9e9eeca7b1af9a107da
-SIZE (erlang/otp_doc_man_R14B04.tar.gz) = 1117663
-SHA256 (erlang/otp_doc_html_R14B04.tar.gz) = 3b066d23d82667e2d0477856b22ea94262d65baf7366babe1c10d8bddc28ab5a
-SIZE (erlang/otp_doc_html_R14B04.tar.gz) = 28816088
+SHA256 (erlang/otp_src_R15B01.tar.gz) = f94f7de7328af3c0cdc42089c1a4ecd03bf98ec680f47eb5e6cddc50261cabde
+SIZE (erlang/otp_src_R15B01.tar.gz) = 75592537
+SHA256 (erlang/otp_doc_man_R15B01.tar.gz) = 5032bcb992369543139136896ba67b4f8fa58fd3d223941a01a39063b221212c
+SIZE (erlang/otp_doc_man_R15B01.tar.gz) = 1287293
+SHA256 (erlang/otp_doc_html_R15B01.tar.gz) = 0b6eb18855b451882ff5be07d3c25b497b256ead14d6be98791bf056b958a8e7
+SIZE (erlang/otp_doc_html_R15B01.tar.gz) = 30235738
SHA256 (erlang/armstrong_thesis_2003.pdf) = da585b914eb07350e2d6f727db5eb0fb1551f49fc1270f7d4dc079f2c8c1ab7a
SIZE (erlang/armstrong_thesis_2003.pdf) = 859249
SHA256 (erlang/bjarnelic.pdf) = 9544d4af5cea324e5c9cf77e670d9561ad61ddc240cdb5c2afecebc0a3d7429b
diff --git a/lang/erlang/files/patch-erts_emulator_drivers_common_inet__drv.c b/lang/erlang/files/patch-erts_emulator_drivers_common_inet__drv.c
deleted file mode 100644
index 889102cce13e..000000000000
--- a/lang/erlang/files/patch-erts_emulator_drivers_common_inet__drv.c
+++ /dev/null
@@ -1,26 +0,0 @@
-
-$FreeBSD$
-
---- erts/emulator/drivers/common/inet_drv.c.orig
-+++ erts/emulator/drivers/common/inet_drv.c
-@@ -3455,17 +3455,9 @@
- /* Check the size of SCTP AssocID -- currently both this driver and the
- Erlang part require 32 bit: */
- ASSERT(sizeof(sctp_assoc_t)==ASSOC_ID_LEN);
--# ifndef LIBSCTP
--# error LIBSCTP not defined
--# endif
-- if (erts_sys_ddll_open_noext(STRINGIFY(LIBSCTP), &h_libsctp, NULL) == 0) {
-- void *ptr;
-- if (erts_sys_ddll_sym(h_libsctp, "sctp_bindx", &ptr) == 0) {
-- p_sctp_bindx = ptr;
-- inet_init_sctp();
-- add_driver_entry(&sctp_inet_driver_entry);
-- }
-- }
-+ p_sctp_bindx = sctp_bindx;
-+ inet_init_sctp();
-+ add_driver_entry(&sctp_inet_driver_entry);
- #endif
-
- /* remove the dummy inet driver */
diff --git a/lang/erlang/pkg-plist b/lang/erlang/pkg-plist
index 4ba9e69b47e5..676df5a45ccc 100644
--- a/lang/erlang/pkg-plist
+++ b/lang/erlang/pkg-plist
@@ -1,3 +1,4 @@
+bin/ct_run
bin/dialyzer
bin/epmd
bin/erl