aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
Diffstat (limited to 'lang')
-rw-r--r--lang/gnustep-base/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/lang/gnustep-base/Makefile b/lang/gnustep-base/Makefile
index 53c2036b73e1..11a5a678e829 100644
--- a/lang/gnustep-base/Makefile
+++ b/lang/gnustep-base/Makefile
@@ -48,6 +48,10 @@ MAKE_APPS= SSL
INSTALL_APPS= SSL
.endif
+.if defined(WITH_GNUSTEP_FAKEMAIN)
+CONFIGURE_ARGS+= --enable-fake-main
+.endif
+
PLIST_SUB+= BASEVERSION=${PORTVERSION:C/[.][0-9]*$//1}
EXTRA_PATCHES+= ${FILESDIR}/NSFileManager.m.patch
@@ -55,6 +59,11 @@ EXTRA_PATCHES+= ${FILESDIR}/NSFileManager.m.patch
PATH:= ${PREFIX}/System/Tools:${PATH}
+.if !defined(GNUSTEP_WITH_BASE_GCC)
+pre-configure:
+ ${LDCONFIG} -m ${TARGLIB}
+.endif
+
post-build:
.for i in ${MAKE_APPS}
(cd ${WRKSRC}/${i}; . ${SYSMAKEDIR}/GNUstep.sh; \