aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
Diffstat (limited to 'lang')
-rw-r--r--lang/libobjc2/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/lang/libobjc2/Makefile b/lang/libobjc2/Makefile
index 8f9d6e8a5d4d..a41aeb730b46 100644
--- a/lang/libobjc2/Makefile
+++ b/lang/libobjc2/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libobjc2
-# Date created: 7 October 2010
-# Whom: Pete French <pete@twisted.org.uk>
-#
+# Created by: Pete French <pete@twisted.org.uk>
# $FreeBSD$
-#
PORTNAME= libobjc2
PORTVERSION= 1.6
@@ -21,14 +17,16 @@ MAKE_ENV+= LD=${LOCALBASE}/bin/ld
MAKE_ENV+= SHLIB_VERSION="${SHLIB_VERSION}"
PLIST_SUB= SHLIB=${SHLIB_VERSION}
-OPTIONS= NSOBJECT_ROOT "Root class is NSObject not Object" On \
- LIBDISPATCH "Build with libdispatch from ports" Off
+OPTIONS_DEFINE= NSOBJECT_ROOT LIBDISPATCH
+OPTIONS_DEFAULT= NSOBJECT_ROOT
+NSOBJECT_ROOT_DESC= Root class is NSObject not Object
+LIBDISPATCH_DESC= Build with libdispatch from ports
SHLIB_VERSION?= 16
.include <bsd.port.options.mk>
-.if defined(WITH_LIBDISPATCH)
+.if ${PORT_OPTIONS:MLIBDISPATCH}
LIB_DEPENDS+= dispatch.0:${PORTSDIR}/devel/libdispatch
MAKE_ARGS+= -DWITHOUT_TOYDISPATCH
PLIST_SUB+= WITH_TOYDISPATCH="@comment "
@@ -36,7 +34,7 @@ PLIST_SUB+= WITH_TOYDISPATCH="@comment "
PLIST_SUB+= WITH_TOYDISPATCH=""
.endif
-.if !defined(WITHOUT_NSOBJECT_ROOT)
+.if ${PORT_OPTIONS:MNSOBJECT_ROOT}
CPPFLAGS+= -DGNUSTEP
.endif
@@ -64,7 +62,7 @@ post-patch:
${RM} ${WRKSRC}/GNUmakefile
post-install:
-.if defined(WITH_LIBDISPATCH)
+.if ${PORT_OPTIONS:MLIBDISPATCH}
${RM} ${PREFIX}/include/objc/toydispatch.h
.endif
ae4d8a'>Use PORTCOMMENT in the Makefile, and whack the pkg-comment.adamw2002-11-072-1/+2 * build with only 1 info fileijliao2002-09-192-6/+9 * upgrade to 1.0p8ijliao2002-09-182-2/+2