aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
Diffstat (limited to 'lang')
-rw-r--r--lang/dmd2/Makefile5
-rw-r--r--lang/dmd2/distinfo6
-rw-r--r--lang/dmd2/files/patch-src__dmd__posix.mak74
-rw-r--r--lang/dmd2/files/patch-src__res__default_ddoc_theme.ddoc116
-rw-r--r--lang/dmd2/pkg-plist40
5 files changed, 225 insertions, 16 deletions
diff --git a/lang/dmd2/Makefile b/lang/dmd2/Makefile
index 27dfb74a6c6a..3d5b2b3778e1 100644
--- a/lang/dmd2/Makefile
+++ b/lang/dmd2/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= dmd
-PORTVERSION= 2.071.1
+PORTVERSION= 2.073.0
CATEGORIES= lang
MASTER_SITES= http://ftp.digitalmars.com/
PKGNAMESUFFIX= 2
@@ -59,6 +59,9 @@ MAKE_ARGS+= DEBUG_FLAGS=-g\ -DDEBUG=1\ -DUNITTEST
MODULEDIR= ${PREFIX}/include/d/phobos2
+pre-patch:
+ @${MKDIR} ${WRKDIR}/dmd2/src/res
+
post-patch:
@${MKDIR} ${WRKDIR}/dmd2/freebsd/bin32 \
${WRKDIR}/dmd2/freebsd/bin64 \
diff --git a/lang/dmd2/distinfo b/lang/dmd2/distinfo
index ab05c400f363..8e39460a67c1 100644
--- a/lang/dmd2/distinfo
+++ b/lang/dmd2/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1467132324
-SHA256 (dmd.2.071.1.freebsd-64.zip) = 8e078b2b35783ef3fd84652b328311f366b06990d2e58de52318fc3b84f0f998
-SIZE (dmd.2.071.1.freebsd-64.zip) = 25188858
+TIMESTAMP = 1487021115
+SHA256 (dmd.2.073.0.freebsd-64.zip) = c7a78632af08e48e0f48fbcfedc228d7b56a35cf1f64f5bee33f79d1d00de4a8
+SIZE (dmd.2.073.0.freebsd-64.zip) = 29122274
SHA256 (dmd.2.067.1.zip) = 24fd32d3b1401309187a3fcd235014e38c651beb3af29b0e656f6f4add4ec95b
SIZE (dmd.2.067.1.zip) = 56083735
diff --git a/lang/dmd2/files/patch-src__dmd__posix.mak b/lang/dmd2/files/patch-src__dmd__posix.mak
index 0ec355366b83..3a137e72ac09 100644
--- a/lang/dmd2/files/patch-src__dmd__posix.mak
+++ b/lang/dmd2/files/patch-src__dmd__posix.mak
@@ -1,14 +1,38 @@
---- ../../src/dmd/posix.mak.orig 2016-04-05 20:46:46.000000000 -0700
-+++ ../../src/dmd/posix.mak 2016-04-07 06:19:55.204336000 -0700
-@@ -66,14 +66,11 @@
- HOST_DMD_RUN:=$(HOST_DMD)
+--- ../../src/dmd/posix.mak.orig 2017-01-22 15:46:00.000000000 -0800
++++ ../../src/dmd/posix.mak 2017-02-13 13:44:37.379009000 -0800
+@@ -19,7 +19,7 @@
+ endif
+
+ INSTALL_DIR=../../install
+-SYSCONFDIR=/etc
++SYSCONFDIR=/usr/local/etc
+ PGO_DIR=$(abspath pgo)
+
+ C=backend
+@@ -42,11 +42,11 @@
+
+ # determine whether CXX is gcc or clang based
+ CXX_VERSION:=$(shell $(CXX) --version)
+-ifneq (,$(findstring g++,$(CXX_VERSION))$(findstring gcc,$(CXX_VERSION))$(findstring GCC,$(CXX_VERSION)))
+- CXX_KIND=g++
++ifneq (,$(findstring c++,$(CXX_VERSION))$(findstring gcc,$(CXX_VERSION))$(findstring GCC,$(CXX_VERSION)))
++ CXX_KIND=c++
+ endif
+ ifneq (,$(findstring clang,$(CXX_VERSION)))
+- CXX_KIND=clang++
++ CXX_KIND=clanc++
+ endif
+
+ HOST_DC?=
+@@ -67,14 +67,12 @@
else
# Auto-bootstrapping, will download dmd automatically
+ # Keep var below in sync with other occurrences of that variable, e.g. in circleci.sh
- HOST_DMD_VER=2.068.2
- HOST_DMD_ROOT=/tmp/.host_dmd-$(HOST_DMD_VER)
-- # dmd.2.068.2.osx.zip or dmd.2.068.2.linux.tar.xz
+ HOST_DMD_VER=2.067.1
+ HOST_DMD_ROOT=${WRKDIR}/.host_dmd-$(HOST_DMD_VER)
+ # dmd.2.068.2.osx.zip or dmd.2.068.2.linux.tar.xz
HOST_DMD_BASENAME=dmd.$(HOST_DMD_VER).$(OS)$(if $(filter $(OS),freebsd),-$(MODEL),)
- # http://downloads.dlang.org/releases/2.x/2.068.2/dmd.2.068.2.linux.tar.xz
- HOST_DMD_URL=http://downloads.dlang.org/releases/2.x/$(HOST_DMD_VER)/$(HOST_DMD_BASENAME)
@@ -18,7 +42,43 @@
HOST_DMD_RUN=$(HOST_DMD) -conf=$(dir $(HOST_DMD))dmd.conf
endif
-@@ -333,19 +330,6 @@
+@@ -103,7 +101,7 @@
+ -Wno-unused-value \
+ -Wno-unused-variable
+ # GCC Specific
+-ifeq ($(CXX_KIND), g++)
++ifeq ($(CXX_KIND), c++)
+ WARNINGS += \
+ -Wno-logical-op \
+ -Wno-narrowing \
+@@ -111,7 +109,7 @@
+ -Wno-uninitialized
+ endif
+ # Clang Specific
+-ifeq ($(HOST_CXX_KIND), clang++)
++ifeq ($(HOST_CXX_KIND), clanc++)
+ WARNINGS += \
+ -Wno-tautological-constant-out-of-range-compare \
+ -Wno-tautological-compare \
+@@ -123,7 +121,7 @@
+ # Default Warnings
+ WARNINGS := -Wno-deprecated -Wstrict-aliasing
+ # Clang Specific
+-ifeq ($(CXX_KIND), clang++)
++ifeq ($(CXX_KIND), clanc++)
+ WARNINGS += \
+ -Wno-logical-op-parentheses \
+ -Wno-dynamic-class-memaccess \
+@@ -141,7 +139,7 @@
+ -D__pascal= -DMARS=1 -DTARGET_$(OS_UPCASE)=1 -DDM_TARGET_CPU_$(TARGET_CPU)=1 \
+ $(MODEL_FLAG)
+ # GCC Specific
+-ifeq ($(CXX_KIND), g++)
++ifeq ($(CXX_KIND), c++)
+ CXXFLAGS += \
+ -std=gnu++98
+ endif
+@@ -342,19 +340,6 @@
verstr.h SYSCONFDIR.imp core *.cov *.deps *.gcda *.gcno *.a *.lst
@[ ! -d ${PGO_DIR} ] || echo You should issue manually: rm -rf ${PGO_DIR}
@@ -38,7 +98,7 @@
######## generate a default dmd.conf
define DEFAULT_DMD_CONF
-@@ -452,7 +436,7 @@
+@@ -461,7 +446,7 @@
$(eval bin_dir=$(if $(filter $(OS),osx), bin, bin$(MODEL)))
mkdir -p $(INSTALL_DIR)/$(OS)/$(bin_dir)
cp dmd $(INSTALL_DIR)/$(OS)/$(bin_dir)/dmd
diff --git a/lang/dmd2/files/patch-src__res__default_ddoc_theme.ddoc b/lang/dmd2/files/patch-src__res__default_ddoc_theme.ddoc
new file mode 100644
index 000000000000..e779c8d6ddd3
--- /dev/null
+++ b/lang/dmd2/files/patch-src__res__default_ddoc_theme.ddoc
@@ -0,0 +1,116 @@
+--- ../../src/res/default_ddoc_theme.ddoc.orig 2017-02-13 14:01:32.569832000 -0800
++++ ../../src/res/default_ddoc_theme.ddoc 2017-02-13 14:01:36.105742000 -0800
+@@ -0,0 +1,113 @@
++DDOC = <html><head>
++ $(DDOC_COMMENT Generated by Ddoc from $(SRCFILENAME))
++ <META http-equiv=\"content-type\" content=\"text/html; charset=utf-8\">
++ <title>$(TITLE)</title>
++ </head><body>
++ <h1>$(TITLE)</h1>
++$(BODY)
++ <hr>$(SMALL Page generated by $(LINK2 http://dlang.org/ddoc.html, Ddoc). $(COPYRIGHT))
++ </body></html>
++
++B = <b>$0</b>
++I = <i>$0</i>
++U = <u>$0</u>
++P = <p>$0</p>
++DL = <dl>$0</dl>
++DT = <dt>$0</dt>
++DD = <dd>$0</dd>
++TABLE = <table>$0</table>
++TR = <tr>$0</tr>
++TH = <th>$0</th>
++TD = <td>$0</td>
++OL = <ol>$0</ol>
++UL = <ul>$0</ul>
++LI = <li>$0</li>
++BIG = <big>$0</big>
++SMALL = <small>$0</small>
++BR = <br>
++LINK = <a href=\"$0\">$0</a>
++LINK2 = <a href=\"$1\">$+</a>
++LPAREN= (
++RPAREN= )
++BACKTICK= `
++DOLLAR= $
++DEPRECATED= $0
++
++RED = <font color=red>$0</font>
++BLUE = <font color=blue>$0</font>
++GREEN = <font color=green>$0</font>
++YELLOW =<font color=yellow>$0</font>
++BLACK = <font color=black>$0</font>
++WHITE = <font color=white>$0</font>
++
++D_CODE = <pre class=\"d_code\">$0</pre>
++DDOC_BACKQUOTED = $(D_INLINECODE $0)
++D_INLINECODE = <pre style=\"display:inline;\" class=\"d_inline_code\">$0</pre>
++D_COMMENT = $(GREEN $0)
++D_STRING = $(RED $0)
++D_KEYWORD = $(BLUE $0)
++D_PSYMBOL = $(U $0)
++D_PARAM = $(I $0)
++
++DDOC_COMMENT = <!-- $0 -->
++DDOC_DECL = $(DT $(BIG $0))
++DDOC_DECL_DD = $(DD $0)
++DDOC_DITTO = $(BR)$0
++DDOC_SECTIONS = $0
++DDOC_SUMMARY = $0$(BR)$(BR)
++DDOC_DESCRIPTION = $0$(BR)$(BR)
++DDOC_AUTHORS = $(B Authors:)$(BR)
++$0$(BR)$(BR)
++DDOC_BUGS = $(RED BUGS:)$(BR)
++$0$(BR)$(BR)
++DDOC_COPYRIGHT = $(B Copyright:)$(BR)
++$0$(BR)$(BR)
++DDOC_DATE = $(B Date:)$(BR)
++$0$(BR)$(BR)
++DDOC_DEPRECATED = $(RED Deprecated:)$(BR)
++$0$(BR)$(BR)
++DDOC_EXAMPLES = $(B Examples:)$(BR)
++$0$(BR)$(BR)
++DDOC_HISTORY = $(B History:)$(BR)
++$0$(BR)$(BR)
++DDOC_LICENSE = $(B License:)$(BR)
++$0$(BR)$(BR)
++DDOC_RETURNS = $(B Returns:)$(BR)
++$0$(BR)$(BR)
++DDOC_SEE_ALSO = $(B See Also:)$(BR)
++$0$(BR)$(BR)
++DDOC_STANDARDS = $(B Standards:)$(BR)
++$0$(BR)$(BR)
++DDOC_THROWS = $(B Throws:)$(BR)
++$0$(BR)$(BR)
++DDOC_VERSION = $(B Version:)$(BR)
++$0$(BR)$(BR)
++DDOC_SECTION_H = $(B $0)$(BR)
++DDOC_SECTION = $0$(BR)$(BR)
++DDOC_MEMBERS = $(DL $0)
++DDOC_MODULE_MEMBERS = $(DDOC_MEMBERS $0)
++DDOC_CLASS_MEMBERS = $(DDOC_MEMBERS $0)
++DDOC_STRUCT_MEMBERS = $(DDOC_MEMBERS $0)
++DDOC_ENUM_MEMBERS = $(DDOC_MEMBERS $0)
++DDOC_TEMPLATE_MEMBERS = $(DDOC_MEMBERS $0)
++DDOC_ENUM_BASETYPE = $0
++DDOC_PARAMS = $(B Params:)$(BR)
++$(TABLE $0)$(BR)
++DDOC_PARAM_ROW = $(TR $0)
++DDOC_PARAM_ID = $(TD $0)
++DDOC_PARAM_DESC = $(TD $0)
++DDOC_BLANKLINE = $(BR)$(BR)
++
++DDOC_ANCHOR = <a name=\"$1\"></a>
++DDOC_PSYMBOL = $(U $0)
++DDOC_PSUPER_SYMBOL = $(U $0)
++DDOC_KEYWORD = $(B $0)
++DDOC_PARAM = $(I $0)
++DDOC_CONSTRAINT = $(DDOC_CONSTRAINT) if ($0)
++DDOC_OVERLOAD_SEPARATOR =
++DDOC_TEMPLATE_PARAM_LIST = $0
++DDOC_TEMPLATE_PARAM = $0
++
++ESCAPES = /</&lt;/
++ />/&gt;/
++ /&/&amp;/
diff --git a/lang/dmd2/pkg-plist b/lang/dmd2/pkg-plist
index c6c8efc66222..c4d288b5a11b 100644
--- a/lang/dmd2/pkg-plist
+++ b/lang/dmd2/pkg-plist
@@ -66,9 +66,9 @@ include/d/druntime/import/core/stdc/string.d
include/d/druntime/import/core/stdc/tgmath.d
include/d/druntime/import/core/stdc/time.d
include/d/druntime/import/core/stdc/wchar_.d
+include/d/druntime/import/core/stdc/wctype.d
include/d/druntime/import/core/stdcpp/exception.d
include/d/druntime/import/core/stdcpp/typeinfo.d
-include/d/druntime/import/core/stdc/wctype.d
include/d/druntime/import/core/sync/barrier.di
include/d/druntime/import/core/sync/condition.di
include/d/druntime/import/core/sync/config.di
@@ -76,8 +76,23 @@ include/d/druntime/import/core/sync/exception.di
include/d/druntime/import/core/sync/mutex.di
include/d/druntime/import/core/sync/rwmutex.di
include/d/druntime/import/core/sync/semaphore.di
+include/d/druntime/import/core/sys/darwin/execinfo.d
+include/d/druntime/import/core/sys/darwin/mach/dyld.d
+include/d/druntime/import/core/sys/darwin/mach/getsect.d
+include/d/druntime/import/core/sys/darwin/mach/kern_return.d
+include/d/druntime/import/core/sys/darwin/mach/loader.d
+include/d/druntime/import/core/sys/darwin/mach/port.d
+include/d/druntime/import/core/sys/darwin/mach/semaphore.d
+include/d/druntime/import/core/sys/darwin/mach/thread_act.d
+include/d/druntime/import/core/sys/darwin/pthread.d
+include/d/druntime/import/core/sys/darwin/sys/cdefs.d
+include/d/druntime/import/core/sys/darwin/sys/event.d
+include/d/druntime/import/core/sys/darwin/sys/mman.d
include/d/druntime/import/core/sys/freebsd/dlfcn.d
include/d/druntime/import/core/sys/freebsd/execinfo.d
+include/d/druntime/import/core/sys/freebsd/pthread_np.d
+include/d/druntime/import/core/sys/freebsd/sys/_bitset.d
+include/d/druntime/import/core/sys/freebsd/sys/_cpuset.d
include/d/druntime/import/core/sys/freebsd/sys/cdefs.d
include/d/druntime/import/core/sys/freebsd/sys/elf.d
include/d/druntime/import/core/sys/freebsd/sys/elf32.d
@@ -94,18 +109,25 @@ include/d/druntime/import/core/sys/linux/epoll.d
include/d/druntime/import/core/sys/linux/errno.d
include/d/druntime/import/core/sys/linux/execinfo.d
include/d/druntime/import/core/sys/linux/fcntl.d
+include/d/druntime/import/core/sys/linux/ifaddrs.d
include/d/druntime/import/core/sys/linux/link.d
+include/d/druntime/import/core/sys/linux/sched.d
+include/d/druntime/import/core/sys/linux/sys/auxv.d
include/d/druntime/import/core/sys/linux/sys/inotify.d
include/d/druntime/import/core/sys/linux/sys/mman.d
+include/d/druntime/import/core/sys/linux/sys/netinet/tcp.d
+include/d/druntime/import/core/sys/linux/sys/prctl.d
include/d/druntime/import/core/sys/linux/sys/signalfd.d
include/d/druntime/import/core/sys/linux/sys/socket.d
include/d/druntime/import/core/sys/linux/sys/sysinfo.d
+include/d/druntime/import/core/sys/linux/sys/time.d
include/d/druntime/import/core/sys/linux/sys/xattr.d
include/d/druntime/import/core/sys/linux/termios.d
include/d/druntime/import/core/sys/linux/time.d
include/d/druntime/import/core/sys/linux/timerfd.d
include/d/druntime/import/core/sys/linux/tipc.d
include/d/druntime/import/core/sys/linux/unistd.d
+include/d/druntime/import/core/sys/openbsd/dlfcn.d
include/d/druntime/import/core/sys/osx/execinfo.d
include/d/druntime/import/core/sys/osx/mach/dyld.d
include/d/druntime/import/core/sys/osx/mach/getsect.d
@@ -123,7 +145,9 @@ include/d/druntime/import/core/sys/posix/dirent.d
include/d/druntime/import/core/sys/posix/dlfcn.d
include/d/druntime/import/core/sys/posix/fcntl.d
include/d/druntime/import/core/sys/posix/grp.d
+include/d/druntime/import/core/sys/posix/iconv.d
include/d/druntime/import/core/sys/posix/inttypes.d
+include/d/druntime/import/core/sys/posix/libgen.d
include/d/druntime/import/core/sys/posix/net/if_.d
include/d/druntime/import/core/sys/posix/netdb.d
include/d/druntime/import/core/sys/posix/netinet/in_.d
@@ -137,6 +161,8 @@ include/d/druntime/import/core/sys/posix/setjmp.d
include/d/druntime/import/core/sys/posix/signal.d
include/d/druntime/import/core/sys/posix/stdio.d
include/d/druntime/import/core/sys/posix/stdlib.d
+include/d/druntime/import/core/sys/posix/sys/filio.d
+include/d/druntime/import/core/sys/posix/sys/ioccom.d
include/d/druntime/import/core/sys/posix/sys/ioctl.d
include/d/druntime/import/core/sys/posix/sys/ipc.d
include/d/druntime/import/core/sys/posix/sys/mman.d
@@ -147,6 +173,7 @@ include/d/druntime/import/core/sys/posix/sys/socket.d
include/d/druntime/import/core/sys/posix/sys/stat.d
include/d/druntime/import/core/sys/posix/sys/statvfs.d
include/d/druntime/import/core/sys/posix/sys/time.d
+include/d/druntime/import/core/sys/posix/sys/ttycom.d
include/d/druntime/import/core/sys/posix/sys/types.d
include/d/druntime/import/core/sys/posix/sys/uio.d
include/d/druntime/import/core/sys/posix/sys/un.d
@@ -396,7 +423,6 @@ include/d/phobos2/std/container/rbtree.d
include/d/phobos2/std/container/slist.d
include/d/phobos2/std/container/util.d
include/d/phobos2/std/conv.d
-include/d/phobos2/std/cstream.d
include/d/phobos2/std/csv.d
include/d/phobos2/std/datetime.d
include/d/phobos2/std/demangle.d
@@ -404,6 +430,7 @@ include/d/phobos2/std/digest/crc.d
include/d/phobos2/std/digest/digest.d
include/d/phobos2/std/digest/hmac.d
include/d/phobos2/std/digest/md.d
+include/d/phobos2/std/digest/murmurhash.d
include/d/phobos2/std/digest/ripemd.d
include/d/phobos2/std/digest/sha.d
include/d/phobos2/std/encoding.d
@@ -441,12 +468,14 @@ include/d/phobos2/std/experimental/ndslice/package.d
include/d/phobos2/std/experimental/ndslice/selection.d
include/d/phobos2/std/experimental/ndslice/slice.d
include/d/phobos2/std/experimental/note.md
+include/d/phobos2/std/experimental/typecons.d
include/d/phobos2/std/file.d
include/d/phobos2/std/format.d
include/d/phobos2/std/functional.d
include/d/phobos2/std/getopt.d
include/d/phobos2/std/internal/cstring.d
include/d/phobos2/std/internal/digest/sha_SSSE3.d
+include/d/phobos2/std/internal/encodinginit.d
include/d/phobos2/std/internal/math/biguintcore.d
include/d/phobos2/std/internal/math/biguintnoasm.d
include/d/phobos2/std/internal/math/biguintx86.d
@@ -479,20 +508,21 @@ include/d/phobos2/std/range/interfaces.d
include/d/phobos2/std/range/package.d
include/d/phobos2/std/range/primitives.d
include/d/phobos2/std/regex/internal/backtracking.d
+include/d/phobos2/std/regex/internal/bitnfa.d
include/d/phobos2/std/regex/internal/generator.d
include/d/phobos2/std/regex/internal/ir.d
-include/d/phobos2/std/regex/internal/kickstart.d
include/d/phobos2/std/regex/internal/parser.d
+include/d/phobos2/std/regex/internal/shiftor.d
include/d/phobos2/std/regex/internal/tests.d
+include/d/phobos2/std/regex/internal/tests2.d
+include/d/phobos2/std/regex/internal/tests3.d
include/d/phobos2/std/regex/internal/thompson.d
include/d/phobos2/std/regex/package.d
include/d/phobos2/std/signals.d
include/d/phobos2/std/socket.d
-include/d/phobos2/std/socketstream.d
include/d/phobos2/std/stdint.d
include/d/phobos2/std/stdio.d
include/d/phobos2/std/stdiobase.d
-include/d/phobos2/std/stream.d
include/d/phobos2/std/string.d
include/d/phobos2/std/system.d
include/d/phobos2/std/traits.d