aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
Diffstat (limited to 'lang')
-rw-r--r--lang/perl5.18/Makefile2
-rw-r--r--lang/perl5.18/files/patch-BigInt.pm11
2 files changed, 12 insertions, 1 deletions
diff --git a/lang/perl5.18/Makefile b/lang/perl5.18/Makefile
index 1cfa3af60018..c8f1a47a7bfc 100644
--- a/lang/perl5.18/Makefile
+++ b/lang/perl5.18/Makefile
@@ -3,7 +3,7 @@
PORTNAME= perl
PORTVERSION= ${PERL_VERSION}
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= lang devel perl5
MASTER_SITES= CPAN \
${MASTER_SITE_LOCAL:S/$/:local/} \
diff --git a/lang/perl5.18/files/patch-BigInt.pm b/lang/perl5.18/files/patch-BigInt.pm
new file mode 100644
index 000000000000..8c56e2859ff4
--- /dev/null
+++ b/lang/perl5.18/files/patch-BigInt.pm
@@ -0,0 +1,11 @@
+--- dist/Math-BigInt/lib/Math/BigInt.pm-orig 2014-06-09 16:22:23.000000000 +0200
++++ dist/Math-BigInt/lib/Math/BigInt.pm 2014-06-09 16:22:54.000000000 +0200
+@@ -62,7 +62,7 @@
+ '>>=' => sub { $_[0]->brsft($_[1]); },
+
+ # not supported by Perl yet
+-'..' => \&_pointpoint,
++# '..' => \&_pointpoint,
+
+ '<=>' => sub { my $rc = $_[2] ?
+ ref($_[0])->bcmp($_[1],$_[0]) :