aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
Diffstat (limited to 'lang')
-rw-r--r--lang/p5-Tcl/Makefile2
-rw-r--r--lang/p5-Tcl/distinfo4
-rw-r--r--lang/p5-Tcl/pkg-descr37
3 files changed, 19 insertions, 24 deletions
diff --git a/lang/p5-Tcl/Makefile b/lang/p5-Tcl/Makefile
index dc62c9fc19ce..f404627c5161 100644
--- a/lang/p5-Tcl/Makefile
+++ b/lang/p5-Tcl/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Tcl
-PORTVERSION= 1.00
+PORTVERSION= 1.02
CATEGORIES= lang perl5
MASTER_SITES= CPAN/../../authors/id/V/VK/VKON/
PKGNAMEPREFIX= p5-
diff --git a/lang/p5-Tcl/distinfo b/lang/p5-Tcl/distinfo
index 85bbceb196d2..3b544f778007 100644
--- a/lang/p5-Tcl/distinfo
+++ b/lang/p5-Tcl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Tcl-1.00.tar.gz) = 9e1cb1c04a84690fdb8d34403b1a2a82e9ddae1492cf1d90db26b33dc93ab8b7
-SIZE (Tcl-1.00.tar.gz) = 156224
+SHA256 (Tcl-1.02.tar.gz) = dd5bd6607f7ad21881edb695018613267eba43d2a48097d4babf66b6fdacf546
+SIZE (Tcl-1.02.tar.gz) = 157789
diff --git a/lang/p5-Tcl/pkg-descr b/lang/p5-Tcl/pkg-descr
index a08306485dc8..985d46e0496e 100644
--- a/lang/p5-Tcl/pkg-descr
+++ b/lang/p5-Tcl/pkg-descr
@@ -1,27 +1,22 @@
The Tcl extension module gives access to the Tcl library with functionality and
interface similar to the C functions of Tcl. In other words, you can:
-create Tcl interpreters
- The Tcl interpreters so created are Perl objects whose destructors
- delete the interpreters cleanly when appropriate.
-
-execute Tcl code in an interpreter
- The code can come from strings, files or Perl filehandles.
-
-bind in new Tcl procedures
- The new procedures can be either C code (with addresses presumably
- obtained using dl_open and dl_find_symbol) or Perl subroutines (by name,
- reference or as anonymous subs). The (optional) deleteProc callback in
- the latter case is another perl subroutine which is called when the
- command is explicitly deleted by name or else when the destructor for
- the interpreter object is explicitly or implicitly called.
-
-Manipulate the result field of a Tcl interpreter
-
-Set and get values of variables in a Tcl interpreter
-
-Tie perl variables to variables in a Tcl interpreter
- The variables can be either scalars or hashes.
+- Create Tcl interpreters
+ The Tcl interpreters so created are Perl objects whose destructors delete the
+ interpreters cleanly when appropriate.
+- Execute Tcl code in an interpreter
+ The code can come from strings, files or Perl filehandles.
+- Bind in new Tcl procedures
+ The new procedures can be either C code (with addresses presumably obtained
+ using dl_open and dl_find_symbol) or Perl subroutines (by name, reference or
+ as anonymous subs). The (optional) deleteProc callback in the latter case is
+ another perl subroutine which is called when the command is explicitly
+ deleted by name or else when the destructor for the interpreter object is
+ explicitly or implicitly called.
+- Manipulate the result field of a Tcl interpreter
+- Set and get values of variables in a Tcl interpreter
+- Tie perl variables to variables in a Tcl interpreter
+ The variables can be either scalars or hashes.
Github repository is at https://github.com/gisle/tcl.pm