aboutsummaryrefslogtreecommitdiffstats
path: root/mail/claws-mail/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/claws-mail/Makefile')
-rw-r--r--mail/claws-mail/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/mail/claws-mail/Makefile b/mail/claws-mail/Makefile
index 74eb7504cda8..7fe16530b122 100644
--- a/mail/claws-mail/Makefile
+++ b/mail/claws-mail/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= sylpheed-claws
-PORTVERSION= 0.9.11
+PORTVERSION= 0.9.12
CATEGORIES= mail news ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= sylpheed-claws
-DISTNAME= sylpheed-${PORTVERSION}claws
+#DISTNAME= sylpheed-${PORTVERSION}claws
DISTFILES= ${EXTRACT_ONLY} \
${THEMEFILE}
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
@@ -30,6 +30,7 @@ USE_X_PREFIX= yes
USE_LIBTOOL_VER=13
USE_GNOME= gnomehack pkgconfig gtk12
USE_REINPLACE= yes
+WANT_GNOME= yes
MAN1= sylpheed-claws.1
@@ -45,6 +46,12 @@ CONFIGURE_ARGS= --enable-openssl --with-openssl-includes=${OPENSSLINC} \
.include <bsd.port.pre.mk>
+.if ${HAVE_GNOME:Mgnomehier} != ""
+PLIST_SUB+= GNOME=""
+.else
+PLIST_SUB+= GNOME="@comment "
+.endif
+
CONFIGURE_ARGS+= --program-suffix="-claws" --enable-ipv6
CONFIGURE_ENV= CFLAGS="${CFLAGS}" CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \