aboutsummaryrefslogtreecommitdiffstats
path: root/mail/claws-mail
diff options
context:
space:
mode:
Diffstat (limited to 'mail/claws-mail')
-rw-r--r--mail/claws-mail/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/mail/claws-mail/Makefile b/mail/claws-mail/Makefile
index 5a8cb56fc69d..9e98ec8ce43a 100644
--- a/mail/claws-mail/Makefile
+++ b/mail/claws-mail/Makefile
@@ -43,8 +43,6 @@ CONFIGURE_ARGS= --program-suffix="-claws" --enable-ipv6 \
CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" \
CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="-L${X11BASE}/lib -L${LOCALBASE}/lib" \
- OPENSSL_CFLAGS="-I${OPENSSLINC}" \
- OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto -lssl" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
OPTIONS= ALL "Enable all options." off \
@@ -71,6 +69,8 @@ EXTRA_PATCHES= ${FILESDIR}/extra-doc:Makefile.in
.include "${PORTSDIR}/Mk/bsd.openssl.mk"
CONFIGURE_ARGS+= --enable-openssl --with-openssl-includes=${OPENSSLINC} \
--with-openssl-libs=${OPENSSLLIB}
+CONFIGURE_ENV+= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
+ OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto -lssl"
.else
CONFIGURE_ARGS+= --disable-openssl
.endif