aboutsummaryrefslogtreecommitdiffstats
path: root/mail/cone/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/cone/Makefile')
-rw-r--r--mail/cone/Makefile21
1 files changed, 11 insertions, 10 deletions
diff --git a/mail/cone/Makefile b/mail/cone/Makefile
index 92a1b9675592..d1c2d2f8456e 100644
--- a/mail/cone/Makefile
+++ b/mail/cone/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= cone
-PORTVERSION= 0.56
-PORTREVISION= 1
+PORTVERSION= 0.58
CATEGORIES= mail
# This is for beta versions, leave it in please:
#MASTER_SITES= http://www.courier-mta.org/beta/${PORTNAME}/
@@ -20,10 +19,14 @@ COMMENT= Console based mail client with POP3/IMAP/SMAP support
LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2 \
aspell.15:${PORTSDIR}/textproc/aspell \
- ncurses.5:${PORTSDIR}/devel/ncurses
+ ncurses.5:${PORTSDIR}/devel/ncurses \
+ fam.0:${PORTSDIR}/devel/fam
BUILD_DEPENDS= gpg:${PORTSDIR}/security/gnupg
RUN_DEPENDS= ${BUILD_DEPENDS}
+USE_GETTEXT= yes
+USE_ICONV= yes
+
USE_BZIP2= yes
USE_PERL5= yes
USE_GMAKE= yes
@@ -34,18 +37,16 @@ CONFIGURE_ENV= REHASH="${PERL} ${SCRIPTDIR}/c_rehash" LDFLAGS=-L${LOCALBASE}/lib
CPPFLAGS=-I${LOCALBASE}/include
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= cone.1 leaf.1 mailtool.1
-
-do-install:
- cd ${WRKSRC} && make install-strip
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/ChangeLog ${DOCSDIR}
-.endif
+INSTALL_TARGET= install-strip
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/sysconftool ${PREFIX}/sbin/cone-sysconftool
PKG_PREFIX=${PREFIX} ${SH} pkg-install ${PORTNAME} POST-INSTALL
${RM} -f ${PREFIX}/share/cone/rootcerts/.0
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/ChangeLog ${DOCSDIR}
+.endif
.include <bsd.port.pre.mk>