aboutsummaryrefslogtreecommitdiffstats
path: root/mail/dspam/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/dspam/Makefile')
-rw-r--r--mail/dspam/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/mail/dspam/Makefile b/mail/dspam/Makefile
new file mode 100644
index 000000000000..b2813c542f20
--- /dev/null
+++ b/mail/dspam/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: dspam
+# Date created: 3 August 2003
+# Whom: Dominic Marks <dom@wirespeed.org.uk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dspam
+PORTVERSION= 2.6.3
+CATEGORIES= mail
+MASTER_SITES= http://www.networkdweebs.com/software/dspam/
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}
+
+MAINTAINER= dom@wirespeed.org.uk
+COMMENT= A server-side bayesian spam filter
+
+LIB_DEPENDS= db41.1:${PORTSDIR}/databases/db41
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-userdir=${PREFIX}/etc/dspam \
+ --with-db4-includes=${LOCALBASE}/include/db41
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
+INSTALLS_SHLIB= yes
+USE_LIBTOOL= yes
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%LIBTOOLFLAGS%%|${LIBTOOLFLAGS}|g ; \
+ s|-ldb-4.1|-ldb41|g' ${WRKSRC}/configure
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${WRKSRC}/CHANGE \
+ ${DOCSDIR}
+.endif
+ @${SED} -e 's,%%PREFIX%%,${PREFIX},g' ${PKGMESSAGE}
+
+.include <bsd.port.mk>