aboutsummaryrefslogtreecommitdiffstats
path: root/mail/exim-doc-html/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/exim-doc-html/Makefile')
-rw-r--r--mail/exim-doc-html/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/mail/exim-doc-html/Makefile b/mail/exim-doc-html/Makefile
new file mode 100644
index 000000000000..bf9cb53e3236
--- /dev/null
+++ b/mail/exim-doc-html/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: exim-doc-html
+# Date created: 27 November 2001
+# Whom: Johann Visagie <wjv@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= exim-doc-${DOCFORMAT}
+PORTVERSION= 3.30
+CATEGORIES= mail
+MASTER_SITES= ftp://ftp.csx.cam.ac.uk/pub/software/email/exim/exim3/ \
+ http://www.exim.org/ftp/exim3/ \
+ ftp://ftp.is.co.za/networking/mail/transport/exim/
+DISTNAME= exim-${DOCFORMAT}-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_BZIP2= yes
+NO_BUILD= yes
+DOCSDIR= ${PREFIX}/share/doc/exim
+PLIST= ${WRKDIR}/pkg-plist
+
+DOCFORMAT?= html
+.if ${DOCFORMAT} != "html" && ${DOCFORMAT} != "pdf" && ${DOCFORMAT} != "postscript"
+.BEGIN:
+ @ ${ECHO} 'ERROR: invalid value for DOCFORMAT: "${DOCFORMAT}"'
+ @ ${ECHO} 'Possible values are "html", "pdf" and "postscript".'
+ @ ${FALSE}
+.endif
+
+pre-install:
+ @ ${CP} ${PKGDIR}/pkg-plist_${DOCFORMAT} ${PLIST}
+
+do-install:
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${DOCSDIR}
+.if ${DOCFORMAT} == "html"
+ @ ${MKDIR} ${DOCSDIR}/html
+ @ ${INSTALL_DATA} ${WRKSRC}/doc/html/*.html ${DOCSDIR}/html
+ @ ${INSTALL_DATA} ${WRKSRC}/doc/html/*.gif ${DOCSDIR}/html
+.elif ${DOCFORMAT} == "pdf"
+ @ ${INSTALL_DATA} ${WRKSRC}/doc/*.pdf ${DOCSDIR}
+.elif ${DOCFORMAT} == "postscript"
+ @ ${INSTALL_DATA} ${WRKSRC}/doc/*.ps ${DOCSDIR}
+.endif
+.endif
+
+.include <bsd.port.mk>