aboutsummaryrefslogtreecommitdiffstats
path: root/mail/exim/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/exim/Makefile')
-rw-r--r--mail/exim/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index c634107e6923..ba8e023f0803 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -50,10 +50,11 @@ PAM_PLAINTEXT= yes
# NETSCAPE or SOLARIS7.
LDAP_LIB_TYPE=UMICHIGAN
-# Uncomment to compile support for non-standard mailbox formats.
-#WITH_MAILDIR= yes
-#WITH_MAILSTORE= yes
-#WITH_MBX= yes
+# The following options control whether Exim is built with support for
+# additional mailbox formats.
+WITH_MAILDIR?= yes
+WITH_MAILSTORE?= yes
+WITH_MBX?= yes
# You should not need to fiddle with anything below this point.
@@ -123,15 +124,15 @@ SEDLIST+= -e 's,^LOOKUP_LIBS,\#LOOKUP_LIBS,' \
-e 's,^LOOKUP_INCLUDE,\#LOOKUP_INCLUDE,'
.endif
-.if defined(WITH_MAILDIR)
+.if defined(WITH_MAILDIR) && ${WITH_MAILDIR} == "yes"
SEDLIST+= -e 's,^\# SUPPORT_MAILDIR,SUPPORT_MAILDIR,'
.endif
-.if defined(WITH_MAILSTORE)
+.if defined(WITH_MAILSTORE) && ${WITH_MAILSTORE} == "yes"
SEDLIST+= -e 's,^\# SUPPORT_MAILSTORE,SUPPORT_MAILSTORE,'
.endif
-.if defined(WITH_MBX)
+.if defined(WITH_MAILMBX) && ${WITH_MAILMBX} == "yes"
SEDLIST+= -e 's,^\# SUPPORT_MBX,SUPPORT_MBX,'
.endif