aboutsummaryrefslogtreecommitdiffstats
path: root/mail/exim
diff options
context:
space:
mode:
Diffstat (limited to 'mail/exim')
-rw-r--r--mail/exim/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index b05fa9bcb7ab..d501a22d97fe 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -80,8 +80,14 @@ IGNORE= you cannot enable DMARC without SPF and DKIM support
# DANE implies DNSSEC
.if ${PORT_OPTIONS:MDANE}
-.if ! ${PORT_OPTIONS:MDNSSEC}
-IGNORE= you cannot enable DANE without DNSSEC support
+.if ! ${PORT_OPTIONS:MDNSSEC} || ! ${PORT_OPTIONS:MTLS}
+IGNORE= you cannot enable DANE without DNSSEC support or without TLS support
+.endif
+# Use Openssl from the ports
+.if ${OSVERSION} < 1000000
+. if ! ${PORT_OPTIONS:MGNUTLS}
+WITH_OPENSSL_PORT= yes
+. endif
.endif
.endif