aboutsummaryrefslogtreecommitdiffstats
path: root/mail/fetchyahoo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/fetchyahoo/Makefile')
-rw-r--r--mail/fetchyahoo/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/mail/fetchyahoo/Makefile b/mail/fetchyahoo/Makefile
index 693235e97d1b..2a5206268744 100644
--- a/mail/fetchyahoo/Makefile
+++ b/mail/fetchyahoo/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= trevor@FreeBSD.org
COMMENT= Download e-mail from a Yahoo account to a Berkeley mailbox
RUN_DEPENDS= \
- encode-base64:${PORTSDIR}/converters/p5-MIME-Base64 \
+ ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
${SITE_PERL}/IO/Lines.pm:${PORTSDIR}/devel/p5-IO-stringy \
${SITE_PERL}/MIME/Body.pm:${PORTSDIR}/mail/p5-MIME-Tools \
${SITE_PERL}/Mail/Address.pm:${PORTSDIR}/mail/p5-Mail-Tools \
@@ -32,6 +32,10 @@ USE_PERL5= yes
.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires Perl 5.6 or newer. Install lang/perl5.8 and try again.
+.endif
+
.if ${PERL_LEVEL} < 500800
RUN_DEPENDS+= ${SITE_PERL}/Net/Cmd.pm:${PORTSDIR}/net/p5-Net
.endif